Support » Networking WordPress » Localhost Multisite Not Creating Additional Sites

  • Hey all,

    I’ve just enabled Multisite on my localhost. Super user admin dashboard is working, as is the initially created site, permalinks however are not working on that site, and additional sites can be created but I can’t access them.

    I can create additional sites from Sites > Add New menu option but visiting the site or dashboard yields a 404.

    Any thoughts? These are hosted locally on a Mac with MAMP.

    Here’s my .htaccess file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    It could be an httpd.conf issue with allowOverride

    Can you check if that’s set to ALL?

    I’m in the httpd.conf file but I’m not entirely sure which allowOverride should be set to All. There are a number of them, after creating a backup I’ve been playing the settings with no luck.
    Turning this one on, that one on, all of them on, no go.

    I’m having the same exact issues on a localhost, I can create a new site via admin panel, but I can’t access the sites… and the WordPress instillation before the conversion works fine but after the multisite upgrade only the homepage is accessible, sample pages etc… is also 404…

    I hope someone can shed a light on this… Thanks guys!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    This should be in the Virtual Hosts section of my httpd.config file, no?

    The file didn’t include anything similar to the example so I appended it, still with no change.

    This is what the Virtual hosts section of the file is currently looking like.

    ### Section 3: Virtual Hosts
    #
    # VirtualHost: If you want to maintain multiple domains/hostnames on your
    # machine you can setup VirtualHost containers for them. Most configurations
    # use only name-based virtual hosts so the server doesn't need to worry about
    # IP addresses. This is indicated by the asterisks in the directives below.
    #
    # Please see the documentation at
    # <URL:http://httpd.apache.org/docs-2.0/vhosts/>
    # for further details before you try to setup virtual hosts.
    #
    # You may use the command line option '-S' to verify your virtual host
    # configuration.
    
    #
    # Use name-based virtual hosting.
    #
    
    # NameVirtualHost *80
    
    <VirtualHost *:80>
      DocumentRoot /Applications/MAMP/htdocs/wordpress
      <Directory /Applications/MAMP/htdocs/wordpress>
        AllowOverride All
      </Directory>

    Again made no change whatsoever.
    Thanks.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Okay, change it to this:

    <VirtualHost *:80>
      DocumentRoot /Applications/MAMP/htdocs/wordpress
      <Directory /Applications/MAMP/htdocs/wordpress>
        AllowOverride All Fileinfo Options
    </Directory>
    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    permalinks however are not working on that site, and additional sites can be created but I can’t access them.

    This is always always always related to the htacess file not being read.

    Gotta force Apache to read each htaccess file in each vhost – just like Ipstenu shows.

    Whew…

    OK I’m seeing some light here, but I’ve never gone that deep, can anyone tell me what line I should include this code, am I supposed to replace something or just add this set?

    Thanks a bunch!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You have

    <VirtualHost *:80>
      DocumentRoot /Applications/MAMP/htdocs/wordpress
      <Directory /Applications/MAMP/htdocs/wordpress>
        AllowOverride All
      </Directory>

    Change to

    <VirtualHost *:80>
      DocumentRoot /Applications/MAMP/htdocs/wordpress
      <Directory /Applications/MAMP/htdocs/wordpress>
        AllowOverride All Fileinfo Options
    </Directory>

    I’ve updated the httpd.config file and now the Apache won’t start. I’ve quit and restarted MAMP, rebooted my MBP, nothing. Apache and MYSQL ports set to 80 & 3306 respectfully.
    Only thing that seemed to be progress was to completely reinstall MAMP which allowed both Apache & MySQL servers to restart with ports set to 80 & 3306, however I get an error notice in phpMyAdmin

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    I was only able to get this message to appear one time and I’m not sure where the error log is.

    I don’t know if this would mean anything, but after implementing,

    <VirtualHost *:80>
      DocumentRoot /Applications/MAMP/htdocs/wordpress
      <Directory /Applications/MAMP/htdocs/wordpress>
        AllowOverride All Fileinfo Options
    </Directory>

    I was able to access the “Main” sites other pages, which wasn’t working for me before, but still the “Child” sites are 404, when I changed the permalinks to /%postname%/ I lost access to the “Main” sites other pages again so I went back to restore it to default settings…

    im having the same problem, just instaled mu ..with all the steps, result, same problem

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Localhost Multisite Not Creating Additional Sites’ is closed to new replies.