• Hive 4 Apps

    (@hive4apps)


    I´m trying to test email sending for my plugin on localhost. I´m using your plugin.
    My problem is :

    1 – When I clicked on “Allow plugin to send emails using your Google account” I got this :

    Error: invalid_request
    
    Invalid parameter value for redirect_uri: Non-public domains not allowed: https://4-9-6-fr.wp-dev/wp-admin/options-general.php?page=wp-mail-smtp&tab=auth

    2 – Whan I tried to send an email I got this error details :

    Versions:
    WordPress: 4.9.7
    WordPress MS: No
    PHP: 7.0.29
    WP Mail SMTP: 1.3.3
    
    Params:
    Mailer: gmail
    Constants: Yes
    Client ID/Secret: Yes
    Auth Code: No
    Access Token: No
    
    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: Yes
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes
    Apache.mod_security: No
    
    Debug:
    Mailer: Gmail
    cURL error 60: SSL certificate problem: unable to get local issuer certificate (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

    How can I resolve this ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    You don’t have a local SSL certificate for your local server and local domain.
    And also Google doesn’t allow to send emails from non-existent primary domains (like .wp-dev). Try .test or any real .com or something.

    Thread Starter Hive 4 Apps

    (@hive4apps)

    Yes I tried but I got a new problem : Browser security :/
    https://stackoverflow.com/questions/51561387/force-firefox-to-allow-auto-signed-certificate-for-localhost

    Thread Starter Hive 4 Apps

    (@hive4apps)

    Gmail Client OAuth accepts to use localhost only this :

    https://localhost/wp-admin/options-general.php?page=wp-mail-smtp&tab=auth

    So I configured https://localhost to point on one wordpress but with an auto-signed certificate.

    I got the same issue.

    Versions:
    WordPress: 4.9.7
    WordPress MS: No
    PHP: 7.0.29
    WP Mail SMTP: 1.3.3
    
    Params:
    Mailer: gmail
    Constants: No
    Client ID/Secret: Yes
    Auth Code: No
    Access Token: No
    
    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: Yes
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes
    Apache.mod_security: No
    
    Debug:
    Mailer: Gmail
    cURL error 60: SSL certificate problem: unable to get local issuer certificate (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

    Have you ever tested on localhost with an auto-signed certificate ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Localhost Error: invalid_request’ is closed to new replies.