• Umar Mughal

    (@umarmughal)



    Looks good but not able to download image on localhost getting message “Unable to download image to server, please check your server permission” i am on Windows 10 using WAMP, any advice?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author dcooney

    (@dcooney)

    Hi @umarmughal,
    Every server is a little bit different so Iā€™m not totally sure where things are breaking down for you.

    Does the raw image get uploaded to wp-content/uploads/instant-images?

    Cheers.

    Umar Mughal

    (@umarmughal)

    Hi @dcooney,

    It’s weird because rest everything works fine, inside wp-content/uploads/instant-images i see only images i tried to download but 0 bites any idea or wamp settings?

    Regards.

    Plugin Author dcooney

    (@dcooney)

    The specific error you are receiving happens on image download from Unsplash.
    Do you have curl enabled? Because that is where the trouble is happening.

    I have tested the plugin on both WAMP and MAMP and have never had troubles šŸ™

    Umar Mughal

    (@umarmughal)

    Hmmm .. even curl is enabled but still same error, weirdest thing is it’s loading all the images in extension, i can see images New, Popular, Oldest even search images but when download i get error .. not getting this šŸ™

    Plugin Author dcooney

    (@dcooney)

    Yes, your issue is not displaying the images from Unsplash… Nothing needs to be configured for that – it’s a permissions issue (or maybe a missing setting) when creating the image on your localhost.

    Are you a developer if so, you could likely debug by modifying the core plugin file to locate the issue. I realize this isn’t your responsibility, but if you wanted to /plugins/instant-images/api/upload.php on like #70 the issue likely starts.

    One last thought, had you tried opening up 777 permissions on the uploads directory?

    Umar Mughal

    (@umarmughal)

    I think you get it wrong i said images displaying form unsplash in your plugin but not downloading when i click on any image, permission is also set to 777 .. i am not developer so can not debug it, full website on localhost working fine along with all other plugins .. anyway thanks for all your time will try to find out the error if i could and let you know.

    Plugin Author dcooney

    (@dcooney)

    Hi @umarmughal,
    Yea, I understood the issue.
    Sorry I couldn’t be more of a help. If it wasn’t a localhost issue it would have been much easier to help debug.

    Umar Mughal

    (@umarmughal)

    Yes i ll also try it on web server, am sure there wont be any issue .. by the way your all plugins are awesome .. keep up good work šŸ™‚

    Plugin Author dcooney

    (@dcooney)

    Thank you šŸ™‚ Appreciate it.

    Umar Mughal

    (@umarmughal)

    And yes its working on web server as expected but please give option to rename image.

    Plugin Author dcooney

    (@dcooney)

    Ok great.
    There are other plugins in the repo available for this. I don’t want to recreate the wheel or add extra steps into the process of Instant Images.
    https://wordpress.org/plugins/search/Rename+Media/

    If I can solve a way to do unobtrusively then I will add the feature.

    Yes i found plugin for that but i just mean if you ever plan for a new version of this plugin or rewrite code .. keep this option in mind because its awesome to have rename option in this … but still i love it

    timbomckay

    (@timbomckay)

    @umarmughal

    I was having this issue with my local Valet configuration. I just deleted the instant-images directory and created a new one. Not ideal but if it’s working on servers then it’s presumably a simple fix locally.

    I’ve been using Instant Images for a good while and I’ve never had this issue before. Not sure if Instant Images changed something since last time or if I’m on a different computer that’s doing something weird or some Valet update.

    Hope this helps.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this review.