Support » Plugin: WP Knowledgebase » local XAMPP undefined constant KBE_PLUGIN_SLUG error

  • Hello,

    Attempting to build a theme locally that works with WP Knowledgebase plugin, it works perfectly deployed on a hosted server, but throws an error locally. I am using XAMPP (WAMP seems to not work anymore).

    Upon activation, I get this error.

    The plugin generated 381 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    The above error is coupled with this error:

    Notice: Use of undefined constant KBE_PLUGIN_SLUG - assumed 'KBE_PLUGIN_SLUG' in C:\xamp\www\project\wp-content\plugins\wp-knowledgebase\articles\kbe_articles.php on line 30

    I am puzzled as to what this could be, double checking where KBE_PLUGIN_SLUG is defined in wp-knowledgebase.php on line 227, it looks correct! The plugin works fine on a server.

    Has anyone dealt with this on a local dev environment?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Same Error on the Host DEBUGG ON

    KBE_PLUGIN_SLUG get not defined correctly

    Fixed this for me with this fall back on wp-knowledgebase.php on line 227
    Till the Devs find a smarter solution

    if (isset($kbe_settings[‘kbe_plugin_slug’])){
    define(‘KBE_PLUGIN_SLUG’, $kbe_settings[‘kbe_plugin_slug’]);
    }else{
    define(‘KBE_PLUGIN_SLUG’,’Knowledgebase’);
    }

    thanks @metaeditor – bump for the devs.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘local XAMPP undefined constant KBE_PLUGIN_SLUG error’ is closed to new replies.