WordPress.org

Forums

Local WP Installation - MAMP & Mac OS X 10.9 (6 posts)

  1. sav360
    Member
    Posted 1 year ago #

    I am defeated!
    Have attempted pretty much as many suggestions posted on the forum as I can bear...

    I am attempting to install WP locally onto my PC (OS X 10.9) using the MAMP application:

    Having followed all the instructions, this is as far as I can get:

    1) Downloaded and installed MAMP - Apache document root is set to: /Applications/MAMP/htdocs ; PHP version 5.5.3 ; Apache Port-8888 & MySQL port -8889
    Both status lights are green.

    2) phpMyAdmin: Created database called - 'wordpress' (no tables in database if that means anything)

    3) Down loaded WordPress and saved into folder htdocs: /Applications/MAMP/htdocs
    Located wp-config-sample.php and edited the database details as below...

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', ‘wordpress’);

    /** MySQL database username */
    define('DB_USER', ‘root’);

    /** MySQL database password */
    define('DB_PASSWORD', ‘root’);

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');/**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    Once those changes were made, I saved the file as: wp-config.php

    4) I then Returned to safari and entered: http://localhost:8888/wordpress/
    This was returned with - "Error establishing a database connection"

    If I however enter: http://localhost:8888, this returns:
    Index of /
    wordpress/ (if I try and open this wordpress folder it then returns Error establishing
    database connection).

    So, I've tried to re-install WP with the correct edits to WP-CONFIG.php, to no avail.

    I am truly at a loss on how to progress to the WP login page.

    Any assistance will be much appreciated.

    Extract from phpMyAdmin:MySQL

    The MySQL Database can be administrated with phpMyAdmin.

    To connect to the MySQL Server from your own scripts use the following connection parameters:

    Host localhost
    Port 8889
    User root
    Password root
    Example:

    $link = mysql_connect('localhost', 'root', 'root');
    or you can connect using an UNIX Socket:

    Socket /Applications/MAMP/tmp/mysql/mysql.sock
    User root
    Password root

  2. 2ninerniner2
    Member
    Posted 1 year ago #

    Everything looks correct.

    However, I never manually create the wp-config.php from the wp-config-sample.php file; I let the installer do it and have never encountered an install where this didn't work, which includes literally 100s on a Mac using MAMP.

    I would suggest renaming the current wp-config.php (e.g. wp-config-old.php), load the page (http://localhost:8888/wordpress) and then at that screen, just click the "Create a Configuration File" button, fill out the form with the info you have there (which is correct) and see how that goes.

    What this eliminates is any error one may introduce when doing it manually; all it takes is an extra space somewhere or a single character out of place. Additionally, it also eliminates any extra formatting a non-plain-text text editor may introduce. I have successfully used TextEdit on the Mac but some have had issues with it.

  3. kmcm
    Member
    Posted 1 year ago #

    I am having a similar problem, same Mac OS. Have spent over five hours on the five-minute install with no luck, trying with Chrome, Firefox, and Safari. Really frustrated! Same issue, the only way I can get past an error screen in all browsers is by manually configuring a wp-config.php file, which seems to work in that I no longer get an error message in any browser. However, when I point the localhost to the wordpress folder in the htdocs folder in the MAMP application folder, an empty browser window appears; this happens in all three browsers. So it appears MAMP is working fine, but the WordPress installation page--that is supposed to magically appear as in the 50 tutorials I've checked to figure this out--is not happening, instead, just a completely white browser window. I have found nothing to troubleshoot this problem. Please help!

  4. 2ninerniner2
    Member
    Posted 1 year ago #

    Don't know what else to say.

    I just updated to Mavericks on my Mac mini so am running OS X 10.9.1 and Safari 7.0.1 and the default install (in other words, I didn't touch a THING!) of MAMP 2.1.3.

    I timed it: 1 minute and 31 seconds to have a fresh WP3.8 site up and logged into :)

  5. 2ninerniner2
    Member
    Posted 1 year ago #

    The only suggestion I have is to delete your current MAMP, re-install, do NOT touch ANY settings and try again :)

    With MAMP running (both servers "in the green"):

    - from the MAMP panel, click Open start page
    - click phpMyAdmin
    - click the Databases tab
    - in the Create database field, enter wp38 then Create
    - create a new folder in Applications/MAMP/htdocs and name it wp38
    - copy the contents of the extracted WP download into this folder
    - there should now be 20 items in the wp38 folder: 3 folders, 15 PHP files, 1 TXT file and 1 HTML file
    - enter http://localhost:8888/wp38 to start the install
    - at the first screen, click the Create Configuration File button
    - at the next screen, click Let's go!
    - at the next screen enter:

    -- Database Name:wp38
    -- User Name:root
    -- Password:root
    -- Database Host:localhost
    -- Table Prefix:wp_

    - click Submit
    - at the next screen click Run the install
    - at the next screen, fill out as required
    - REMEMBER: the Username and Password you enter HERE, is for the WP Admin Log in. This is what you will use to get to the Dashboard of your WP site.
    - for local installs, I un-check the Privacy option
    - click Install WordPress
    - at the next screen (Success!), click Log In and use the credentials you just entered.

  6. sav360
    Member
    Posted 1 year ago #

    Thanks for the info

    I got it working: As suggested, I took the original WP-config-sample.php and replaced the modified WP-config.php file.

    Its all working great now.

Topic Closed

This topic has been closed to new replies.

About this Topic