Support » Localhost Installs » local site url issue

  • Hi

    I friend of mine and I are working on a site with wordpress and a theme we bought. He is working on his local machine, and I am on mine.

    He sent me the wp-content folder, and exported the database.
    I removed my wp-content folder, pasted his, and deleted the database and imported his database.

    I changed the wp_ prefix to the prefix he was using, and also added to the begining of the wp-config.php file the following:

    define(‘WP_HOME’,’local.woz.com’);
    define(‘WP_SITEURL’,’local.woz.com’);

    that is my local environment url.
    If I go the home it works fine, however, if I try to go to the admin, it tries to go to :

    http://local.woz.com/wp-admin/local.woz.com/wp-login.php?redirect_to=http%3A%2F%2Flocal.woz.com%2Fwp-admin%2F&reauth=1

    I dont have a clue whats happening. As you can see I changed the site url and home url.

    Any help would be much appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Tim Nash

    (@tnash)

    Spam hunter

    the site and home urls, should be full urls including http:// part

    @brsastre

    An even easier solution is to use the All In One WP Migration plugin:

    https://wordpress.org/plugins/all-in-one-wp-migration/

    Here’s how to do it:

    – have your friend install the plugin and then use the Export to File method. Just install, activate, click Export > File > then download when completed (saves to your friend’s Downloads location)
    – have your friend send you that file
    – wherever you are working (local or hosted) the easiest is to install a fresh WP site and don’t do anything to it other than install and activate All In One WP Migration
    – select Import > From File > select the file you received from your friend and follow the prompts
    – when it’s finished, you will log out and back in with the login credentials of your friends install as that is now what is on yours
    – go to Settings > Permalinks and click the Save Changes twice (waiting for it to complete with each one)

    Done 🙂

    Sounds complicated but it only takes a few minutes. This is how I move all of my sites around, either local to live, live to local or any other combination.

    Cheers!
    Lyle

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘local site url issue’ is closed to new replies.