Support » Localhost Installs » Local not working, db differences – using WAMP

  • Resolved seiferflo


    Hi there,

    Here’s the situation.
    I built a website long time ago, I need to make big edits and maybe update wordpress, but I’d like to have it locally.
    I’m using WAMP as local server, I copied all the files and exported the db following your tutorial and I also tried using wp-dbmanager.
    What happens is that my local website is half complete. It doesn’t give me any db not found or something, but on the main page I get the error: The page you requested could not be found. Try refining your search, or use the navigation above to locate the post.

    My menu and background is visible but it sounds like it’s online (if I click a menu, it sends me to the online version of the website)

    It took me 5min to do a similar operation with a Joomla website thanks to akeeba script and it’s been 24h I’m trying to do it with wordpress. I couldn’t find a simple backup solution which works properly with my version of wordpress. So I suspect it’s because I don’t have the proper wamp settings or the db in incorrect.

    Online website is based with the following specs:
    – WordPress 3.2.1
    – Host:
    – phpMyAdmin 2.6.4-pl3
    – mySQL: 5.1.67
    – PHP Version: 5.3.3-7+squeeze15
    – Apache: no idea

    Specs of the local one using WAMP 2.2e:
    – phpMyAdmin 3.5.1
    – mySQL: 5.5.24
    – PHP Version: 5.4.3
    – Apache: 2.4.2

    As you can see the specs don’t match. Yet I was able to import the db and get something.

    – How to get the proper mysql, php and apache version? I can’t find the exact match. I tried to get the Mysql, extract the files, then play with the *.ini file and add wampconfig to make it run with WAMP. Works fine for mysql but PHP gives an error.

    – When comparing the online db and the imported one on the local version, it seems there are identical in terms of tables & records (size is a bit different though Online: 830.2 KB, Local: 852.7 KiB).

    – I deleted the local wp-confip.php, let wordpress start the install and filed it with the followings:
    DB_NAME : db382978911
    DB_USER : root
    DB_HOST : localhost

    What’s the problem? Is it WAMP’s fault or did I miss something?
    Please help me I’m getting nuts.

    Thanks in advance for your help
    Best Regards,

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Local not working, db differences – using WAMP’ is closed to new replies.