WordPress.org

Support

Support » Installation » Local Installation – just lists directory

Local Installation – just lists directory

  • Hi

    I’m painfully new to wordpress and have hit a problem trying to get a local installation to work. I’ve followed the installation instructions and everything seemed fine, installation was successful and I can log in to the back end.

    The problem is when I go to the root http://localhost/wordpress/ I just get a list of the directory. This happens whenever I try to view the site.

    If I create a page by short-cutting to http://localhost/wordpress/wp-admin/profile.php and making a new post, when I view the post (http://localhost/wordpress/page_id=3) I just get a 404.

    Have I missed something obvious in the installation process? Do I need to define the local folder or something? I’ve tried searching out the problem but to no avail..

    Any help much appreciated

    Jake

Viewing 15 replies - 1 through 15 (of 17 total)
  • you have IIS or Apache?

    Hi, yes sorry, when I write “http://localhost/wordpress/?page_id=3?” it just lists the directory.

    I’m running have Apache. Any ideas?

    If you are running Apache take a look at the second comment on this thread.

    Chris_K
    Member

    @handysolo

    configure your web server to treat index.php as a Default file.

    Hi thanks, I searched httpd.conf and couldn’t find the following lines:

    <IfModule dir_module>
        DirectoryIndex index.html index.php
    </IfModule>

    Do I need to add them somewhere?

    Chris, are you talking about the same thing? If not, any pointers as to how to set this up?

    Chris_K
    Member

    @handysolo

    Yep, same thing. And you’ll need those lines. 🙂

    I’ve tried adding those lines in and nothing changed.. is this something I need to do prior to install? ..or might I be missing something else? ..probably really obvious 😉

    Chris_K
    Member

    @handysolo

    You might want to hit a forum more dedicated towards apache support.

    That being said, did you remember to restart apache after changing the .conf file?

    Thanks for the help Chris ..no I didn’t restart Apache, so I’ve just restarted my machine (and also Apache just to make sure) and now when I try index.php I get “Error establishing a database connection”. I’ve checked the wp-config.php file and everything looks correct.. hmmm.. this is getting tricky!

    If the username, password, and database name are correct then is MySql running?

    Nope, MySql wasn’t running any more.. and is now refusing to. I’ve tried restarting my machine, restarting Apache and asking MySql to start but it doesn’t want to play.. no idea what’s going on.

    Think I’ll try to get MySql going again and then try a new install of WordPress.

    Thanks all for the help 🙂

    If MySql crashed you might have a locked file that is preventing it to restart. I’ve had that problem before. I only vaguely remember how I solved it so no promises. If you are running some kind of *NIX try telling mysqld to stop. On Slackware the command would be /etc/rc.d/rc.mysqld stop. It can be different on other systems– something like /etc/rc.d/init.d/mysqld stop. You’ll have to find your mysqld and work out the path. Alternately, and as a last resort, you can find the mysql.sock file and delete it. I’m vaguely sure that nothing bad will happen, but only vaguely. No promises. Of course, if you are not running a *NIX this does you no good.

    Hi.
    I have a similar problem – I can access the WordPress Dashboard, but when I try to view the files the browser takes me to my index.html file, which I’ve not yet taken down.
    Thanks to this thread I now realize that I have to add the coding that you’ve given – but I’ve no idea where to look for httpd.conf.
    It sounds as if it’s part of Apache, which I’m running, but I’ve no idea how to change the configuration. I’ve tried the Apache Handlers link in CPanel, which didn’t seem to help.
    Could you point me in the right direction, please?
    Thanks for your help.
    Aislinn.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Local Installation – just lists directory’ is closed to new replies.