WordPress.org

Support

Support » Installation » [Resolved] local install on XP Pro

[Resolved] local install on XP Pro

  • I would like to run Word Press Locally on XP Pro but cannot make My SQL work in XAMPP. The Apache server starts just fine but the MySQL server starts and stops immediately.

    Thanks for Word Press, it’s great!!!

    Ministermark

Viewing 7 replies - 1 through 7 (of 7 total)
  • Looks like the XAMPP support forums are located at http://www.apachefriends.org/f/

    I tried stopping windows firewall and my Internet security, still no good. I don’t know how to add ports. Matt’s local install page say’s WP will work on XP Pro if you stop IIs. Don’t know what that means either!

    IIS is a service that starts automatically on XP Pro.
    Press ctrl-alt-delete and in the task manager that comes up, stop the iis service. Then see what Xampp does.

    Also run the port-check which is in the xampp directory.

    I have Xampp and IIS together running on one computer. Xampp is looking while installing for ports to use. It can be an option to de install, and then install again. You also have to do your ussername and password for MySql.

    BTW, the firewall doesnt matter. You can leave that one running, but my advise is to look for ZOneAlarm Pro or something.

    TechGnome

    @techgnome

    Moderator

    What does IIS have to do with MySQL??? Please some one tell me. One is a webserver and the other is a database server. They are different and independant of each other.

    That said… is there a chance you have SQL Server running on it? I had a problem with getting MySQL to run a while back and it’s because I had SQL Server running and both were trying to bind to the same port. Once I stopped SQL Server, MySQL fired right up w/o any issues.

    -tg

    IIS have nothing to do with MySql. I dont know how you get does problems because I also have SQL for my ASP development, but did not have any problems installing MySqL

    I found my mistake! The box on XAMPP Control Panel SVC was checked for both Apache and MySQL. I unchecked these and both started right up. Now I’ll follow Matt’s instructions and see what happens. Thanks to you all

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] local install on XP Pro’ is closed to new replies.
Skip to toolbar