Support » Plugin: Payment Plugins for Stripe WooCommerce » Local gateway issue

  • Resolved Heheda

    (@atmercato)


    Hello, I’ve been facing a problem, that after I’ve configured the webhook, I use the local gateway to pay(wechat and alipay), although it redirects to stripe, but after having autorized the payment it doesn’t redirect to the order received page!

Viewing 4 replies - 16 through 19 (of 19 total)
  • Thread Starter Heheda

    (@atmercato)

    So there is a problem with wechat pay, which is another local gateway.

    Plugin Author Payment Plugins

    (@mrclayton)

    @atmercato I tested WeChat and it stays on the Stripe page as you described. That’s part of the WeChat flow I believe. It relies on a QR code so in production there won’t be a redirect like that.

    This isn’t an issue.

    Your webhook is receiving the charge event and completing the processing of the order.

    Plugin Author Payment Plugins

    (@mrclayton)

    @atmercato I did notice you have some JS errors on your checkout page which you will want to resolve.

    Uncaught ReferenceError: pnScriptSetting is not defined.

    That error is unrelated to the Stripe plugin but will cause issues.

    Thread Starter Heheda

    (@atmercato)

    Thank you for remind me for this error. Actually I was trying to set the push notification plugin work since it doesn’t work on pwa.
    Anyway, thank you for your time for trying to find and solve the problem!

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Local gateway issue’ is closed to new replies.