Support » Plugin: Payment Plugins for Stripe WooCommerce » Local gateway issue

  • Resolved Heheda

    (@atmercato)


    Hello, I’ve been facing a problem, that after I’ve configured the webhook, I use the local gateway to pay(wechat and alipay), although it redirects to stripe, but after having autorized the payment it doesn’t redirect to the order received page!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Payment Plugins

    (@mrclayton)

    Hi @atmercato

    What page is it redirecting to on your site after you authorize the payment?

    Kind regards,

    Thread Starter Heheda

    (@atmercato)

    /order-received/grazie/?key=wc_order_VSNMLBdfAVv8s&order_id=1818
    I’m using the nextmove thankyou page plugin.

    Plugin Author Payment Plugins

    (@mrclayton)

    @atmercato is the local payment charge completing?

    Disable that thank you page plugin and test again. If it works fine you know that plugin is interfering with the redirect.

    Thread Starter Heheda

    (@atmercato)

    Hello, I’ve disactivated the thankyou page plugin, but it still doesn’t work. It remains at the stripe page. But as always, it charges.

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @atmercato,

    This is in test mode right? Can you share a website url so I can take a look? These redirect issues are almost never an issue with the Stripe plugin.

    Kind Regards,

    Thread Starter Heheda

    (@atmercato)

    Thread Starter Heheda

    (@atmercato)

    it is in the test mode

    Plugin Author Payment Plugins

    (@mrclayton)

    I am finding it very difficult to navigate your site. You have login required to view the checkout page but when I create an account it just keep’s redirecting me away from the checkout page.

    Some instructions would be helpful.

    Thread Starter Heheda

    (@atmercato)

    You have to verify your account by clicking a link of activation in your email address

    Thread Starter Heheda

    (@atmercato)

    I’ve verified you manually, you can login now

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @atmercato,

    The redirect sent me to https://www.atmercato.it/order-received/grazie/?key=wc_order_LHY8xiIbmp5y4&order_id=1820 which is what I would expect. That’s the thank you page.

    Are you saying you’re expecting it to redirect to a different page? The page it sent me to is the WooCommerce thank you page so it’s working like it’s supposed to.

    Thread Starter Heheda

    (@atmercato)

    It is exactly the page I want.
    But after I’ve autorized the test payment on stripe, it just remains here
    https://ibb.co/HXCRzwd

    Plugin Author Payment Plugins

    (@mrclayton)

    @atmercato That’s weird, you should see the Authorize Test Payment button which I don’t see in your screenshot.

    Here is what I see and when I click that button it works perfectly.

    https://ibb.co/DtwRZC5

    Kind Regards,

    Thread Starter Heheda

    (@atmercato)

    Hello, I’ve tested by myself. It seems like that only the Wechat pay is not working.
    Because alipay is working.

    Plugin Author Payment Plugins

    (@mrclayton)

    @atmercato Alipay worked for me as well. Order #1825.

    Kind Regards,

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Local gateway issue’ is closed to new replies.