Support » Fixing WordPress » Loading authors slows down the page

  • Resolved Humiges

    (@humiges)


    Hello,

    I was just wondering if I can stop loading all users in dropdown on blog_post / pages etc when editing or adding new content/page in wordpress admin.

    We have over 100k users and loading the dropdown takes sometime over a minute.

    I’m not sure if there is an plugin for it… I looked for many hours, but I probably can describe it correctly and because of that, I can’t find a solution for it.

    The list also loads in Quick Edit.

    It would be great to have just a populated field like for example when you start to write a comment with @mention and as soon as you start the usernames start to show.

    Thank you very much šŸ™‚

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    From “screen options”, uncheck “author” and that dropdown will go away.

    See https://i.imgur.com/sQQnb7Z.png

    Hello Humiges,
    If you want as soon as the editor of the post write @mention name in the field and username start to show, then you have to create a custom meta box for that and write some functionality for this. Or if don’t want to load author then just uncheck the author from the screen option of your admin panel.
    Thanks.

    Thread Starter Humiges

    (@humiges)

    Thanks so much @sterndata
    I tried that before and haven’t seen any difference, but it works now.
    Thank you šŸ™‚

    And thank you @themesgrove,
    I’ll look at the custom option… I think it might be quite popular :))

    Have a nice day

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Loading authors slows down the page’ is closed to new replies.