WordPress.org

Forums

Loading a root directory separately with pretty permalinks (5 posts)

  1. dave
    Member
    Posted 1 year ago #

    I'm trying to load a directory containing a mobile web app, located in the root directory of my WP install, but when I load the url it brings me to a 404 page in the WP site.

    I know it's probably an htaccess hack, but I'm not sure what to change. Any ideas?

    This post was close (towards the bottom), but applied to Multi-site, so not exactly: http://wordpress.org/support/topic/adding-files-to-root-directory-with-domain-mapping

  2. Timothy Jacobs
    Member
    Posted 1 year ago #

    Try adding a .htaccess file to your mobile app directory and add this code

    <IfModule mod_rewrite.c>
    
    #Disable rewriting
    RewriteEngine Off
    
    </IfModule>
  3. dave
    Member
    Posted 1 year ago #

    Hm, tried that, but it's still showing the WP site 404 page. Any other ideas?

    The mobile app directory is in the same directory as directories like "wp-content" and "wp-includes", etc. Could this be a problem with my permalink settings thinking /mobileapp/ is a WP page?

  4. Timothy Jacobs
    Member
    Posted 1 year ago #

    Typically, yes. If you turned off pretty permalinks, it shouldn't be an issue, but that wouldn't be a very helpful solution, now would it!

    That usually works for me, try out this one.

  5. dave
    Member
    Posted 1 year ago #

    When I add the line suggested in that post to my htaccess file (with the appropriate directory name obviously), I get a "Malware detected" page, and when I "proceed anyways", it still gives me the "404 Not found".

    Do I need to have the /mobileapp/ folder in a particular directory? Or isn't that htaccess line finding it anywhere under root? (/)

Topic Closed

This topic has been closed to new replies.

About this Topic