• Hello, I am using Foo Gallery and as every person I can say it is one of the best galleries ever 🙂

    My problem: I am using gallery to show my pictures http://www.studioprix.com. The size of pictures is reduced, so this can not be a reason why it loads slow.
    I made pictures to be in two column. When I enter the gallery, first it loads pictures in one column and it takes years to load it. But if I press “Resfresh”, it loads immediately – in one second and in two rows.
    I want pictures to be in two rows, because it’s just too many of them to be in one row and I don’t want to create many pages for every single project.

    How can I make that foo gallery load pictures straight in two rows?


    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You mean two rows or columns?

    If two columns – then use standard responsive gallery with fixed width.

    If two rows, then use justified gallery template.

    Oh, sorry my mistake – I meant two columns.

    The problem is, doesn’t matter that settings I choose, it always first uploads big images in one column and only after I press refresh it makes two columns. If the gallery is bigger, it takes very long to upload it. The page itself and gallery (when it’s two columns) looks very nice, but I can not promote the page while it is not working properly 🙂

    I want to use two column masonry image gallery.
    Please help me.

    I’m pretty sure the issue here is your ajax loading module. Is simply does’t load gallery scripts properly.

    Do you have any idea how could I fix it?
    My friend offered me to try other gallery plugins, but there is nothing even close to foogallery. I had checked everything already…

    Well it’s not guarantee, that other plugins will work, the issue may remain the same.

    From experience i know, that there’s always a lot of issues with ajax loading. It might not be “fixable” as it is.

    Possible solutions:
    1. Check if there’s ajax loader “behaviour” settings in theme options. There might be option to load all scripts first.
    2. Install free albums extension and use them, standard album template uses ajax too, which loads on same page. It might load a bit longer tho.
    3. Your theme have masonry gallery module: http://stockholm13.select-themes.com/portfolio_page/stockholm-destination/
    – why you haven’t used that?
    4. Use other masonry gallery plugin:
    https://pl.wordpress.org/plugins/photoswipe-masonry/
    https://pl.wordpress.org/plugins/simple-masonry-gallery/
    https://pl.wordpress.org/plugins/modula-best-grid-gallery/
    – it’s not really that rare.

    Plugin Author bradvin

    (@bradvin)

    @redabernott what have you set as your thumb width for your galleries?

    The reason for the really long load time is because your thumbs are really big.

    Looking at your page source, your thumbs are 2500 in width, which is really large! Try using a thumb width of 400 and see how that changes your page load times

    Hi @redabernott I am having the same problem. Did you manage to resolve this?

    No, I give up 🙂 What I did I made a collage from photos, so instead of uploading every picture web has to upload 5 big images (with a lot of small mages inside, but he takes it as one file). check in http://www.studioprix photography.

    Also, check if it only your computer uploading slow or the others also. I found out my computer is more slow than I expected 🙂

    But still, this idea with collage was my solution.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Load pictures very slow’ is closed to new replies.