Support » Plugin: Plugin Organizer » Load order not saved after new plugin activation

  • Resolved joshuaiz

    (@joshuaiz)


    Hello,

    Great plugin but having an issue with load order. Saving the load order works but when you activate a new plugin, the order is lost and you have to reorder and save again.

    This is not ideal especially if you are doing testing with other plugins in the admin like Query Monitor which you don’t want to have enabled all the time.

    Not sure where the order is being saved to but if this could be saved perpetually and then new activated plugins added to the bottom of the list would be great.

    http://wordpress.org/plugins/plugin-organizer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    That is exactly what is supposed to happen. So when you activate a plugin and then come back to the plugin screen the plugin is not active anymore?

    So it’s not a bug, it’s a feature 🙂

    No it’s just that when you add + activate a new plugin, the order is lost.

    It would be great to have an option to save the load order and then add any new activated plugin to the bottom of the list.

    Plugin Author Jeff Sterup

    (@foomagoo)

    No I meant that when you activate the new plugin it should be added to the end of the list. The order you have set should not be lost. I’m looking into why this is happening.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Ok so it looks like the load order wasn’t lost. If you click on the active link to see all active plugins the load order is corrected. I just need to add a new function call when a plugin is activated to recreate the load order so you will see it on the page after the plugin is activated. I’m going to release a new version in a little while that will fix this along with another bug. Install the new version when you see it and let me know if it works for you.

    Awesome thanks Jeff!

    Plugin Author Jeff Sterup

    (@foomagoo)

    So I’m guessing its fixed now?

    Yep. This is fixed.

    And I didn’t realize before that the order was saved but on the “Active” tab…

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Load order not saved after new plugin activation’ is closed to new replies.