Support » Plugin: External Links - nofollow, noopener & new window » „Load more products” button doesnt work

  • Resolved cesaicumpar

    (@cesaicumpar)


    Hello! Unfortunately, when the plugin is active, the „Load more products” button on the products page does not work. Right now the plugin is activated and you can check yourselves.

    Is there something I can do?

    Technical info: `WP url: https://cesaicumpar.ro
    WP version: 6.0.1
    PHP version: 8.0.20
    Active Plugins:
    – Classic Widgets, version: 0.3
    – Dashboard Wordcount, version: 0.8
    – Elementor, version: 3.6.7
    – Insert Headers and Footers, version: 1.6.2
    – Loco Translate, version: 2.6.2
    – ShortPixel Image Optimizer, version: 5.0.5
    – Ultimate Addons for Gutenberg, version: 1.25.6
    – UpdraftPlus – Backup/Restore, version: 1.22.14
    – WooCommerce, version: 6.7.0
    – WooCommerce External Product New Tab, version: 1.0.4
    – Woodmart Core, version: 1.0.34
    – WP External Links, version: 2.55
    – WP Rocket, version: 3.11.4.2
    – Yoast SEO, version: 19.3

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ‘nofollow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘rel_external’ => ‘1’,
    ‘rel_sponsored’ => ”,
    ‘rel_ugc’ => ”,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ‘1’,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ‘1’,
    ‘apply_widgets’ => ‘1’,
    ‘skip_post_ids’ => ”,
    ‘ignore_classes’ => ”,
    ‘subdomains_as_internal_links’ => ”,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ”,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ‘1’,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-exit-confirmation-settings’ => array (
    ‘exit_preview’ => ”,
    ‘background’ => ‘#FFFFFF’,
    ‘title’ => ‘You are leaving our website’,
    ‘title_color’ => ‘#FFF’,
    ‘title_background’ => ‘#999’,
    ‘title_size’ => ’18’,
    ‘text’ => ‘This link leads outside our website and we are not responsible for its content. If you still want to visit the link, click here:’,
    ‘text_color’ => ‘#444’,
    ‘text_size’ => ’14’,
    ‘popup_width’ => ‘400’,
    ‘popup_height’ => ‘200’,
    ‘overlay’ => ‘1’,
    ‘overlay_color’ => ‘#000’,
    ‘button_text’ => ‘Stay on the site’,
    ‘button_size’ => ’14’,
    ‘button_color’ => ‘#FFF’,
    ‘button_background’ => ‘#1e73be’,
    ),
    );`

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Alexandru Tapuleasa

    (@talextech)

    Hi,

    In the Exceptions tab, in the box Ignore links by class add wd-load-more. That should fix it 🙂

    Thread Starter cesaicumpar

    (@cesaicumpar)

    It doesn’t work :c

    Plugin Author Alexandru Tapuleasa

    (@talextech)

    Weird, I see WPEL still applies itself to that button 🙁
    Can you copy/paste your WPEL settings export again?

    Thread Starter cesaicumpar

    (@cesaicumpar)

    WP url: https://cesaicumpar.ro
    WP version: 6.0.1
    PHP version: 8.0.20
    Active Plugins:
    – Classic Widgets, version: 0.3
    – Dashboard Wordcount, version: 0.8
    – Elementor, version: 3.6.7
    – Insert Headers and Footers, version: 1.6.2
    – Loco Translate, version: 2.6.2
    – ShortPixel Image Optimizer, version: 5.0.5
    – Ultimate Addons for Gutenberg, version: 1.25.6
    – UpdraftPlus – Backup/Restore, version: 1.22.14
    – WooCommerce, version: 6.7.0
    – WooCommerce External Product New Tab, version: 1.0.4
    – Woodmart Core, version: 1.0.34
    – WP External Links, version: 2.55
    – WP Rocket, version: 3.11.4.2
    – Yoast SEO, version: 19.3

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ‘nofollow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘rel_external’ => ‘1’,
    ‘rel_sponsored’ => ”,
    ‘rel_ugc’ => ”,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ‘1’,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ‘1’,
    ‘apply_widgets’ => ‘1’,
    ‘skip_post_ids’ => ”,
    ‘ignore_classes’ => ‘wd-load-more, load-more-label, wd-loop-footer, products-footer’,
    ‘subdomains_as_internal_links’ => ”,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ”,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ‘1’,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-exit-confirmation-settings’ => array (
    ‘exit_preview’ => ”,
    ‘background’ => ‘#FFFFFF’,
    ‘title’ => ‘You are leaving our website’,
    ‘title_color’ => ‘#FFF’,
    ‘title_background’ => ‘#999’,
    ‘title_size’ => ’18’,
    ‘text’ => ‘This link leads outside our website and we are not responsible for its content. If you still want to visit the link, click here:’,
    ‘text_color’ => ‘#444’,
    ‘text_size’ => ’14’,
    ‘popup_width’ => ‘400’,
    ‘popup_height’ => ‘200’,
    ‘overlay’ => ‘1’,
    ‘overlay_color’ => ‘#000’,
    ‘button_text’ => ‘Stay on the site’,
    ‘button_size’ => ’14’,
    ‘button_color’ => ‘#FFF’,
    ‘button_background’ => ‘#1e73be’,
    ),
    );

    Thread Starter cesaicumpar

    (@cesaicumpar)

    This is a screenshot with the exception: https://imgur.com/a/BdnoKy7

    I added more classes and tried them 1 by 1, but still no luck

    Thread Starter cesaicumpar

    (@cesaicumpar)

    hello?

    Plugin Author Alexandru Tapuleasa

    (@talextech)

    Sorry but I don’t have any ideas 🙁
    Are you sure you tried adding just ‘wd-load-more’ with no spaces before/after?

    Maybe the button classes are added after WPEL parses the links.

    Thread Starter cesaicumpar

    (@cesaicumpar)

    yep, I tried only with that class and it doesn’t work
    if you want, I can give you the login details so you can try more classes?

    Thread Starter cesaicumpar

    (@cesaicumpar)

    I’d appreciate if you wouldn’t mark it as “Resolved” when it is not resolved. Ask for advice on the problem from someone else or tell me to just disable the plugin. Then it will be resolved. But I’m still waiting for your response, and visitors are still not being able to see more than 12 products on the page.

    Plugin Author Alexandru Tapuleasa

    (@talextech)

    Sorry, I just mark them as resolved when I reply so I can see what threads are waiting for my response.
    Unfortunately, we can’t share login on personal info on this forum so there’s nothing I can do 🙁
    You can disable the plugin, I guess it’s just not compatible with something on your website.

    Thread Starter cesaicumpar

    (@cesaicumpar)

    are you sure the exceptions tab works?

    I added every single class on that button, but it still shows it as ‘external’

    Plugin Author WebFactory

    (@webfactory)

    We didn’t have any complaints so far. As Alex said, most probably, it’s an incompatibility with some other plugin you’re using.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.