Support » How-To and Troubleshooting » LivePress 1.5.1 issue

LivePress 1.5.1 issue

  • I had Livepress working fine in 1.5 but after upgrading to 1.5.1 I get the following error.

    Fatal error: Unknown function: get_currentuserinfo() in /home3/trench/public_html/wp-content/plugins/LivePress/lpextras.php on line 93

    I am mostly php illiterate so if somebody could help me I’d be grateful.

Viewing 15 replies - 1 through 15 (of 29 total)
  • 1.5.1 moved the get_currentuserinfo function to a different file, so LivePress doesn’t know where to find it. They are not compatible as is, so I’ve had to hold off upgrading WordPress until Livepress is updated to be compatible.

    LivePress has a similar issue as a plugin of my own, so I duplicated the change from mine to two files (lpsynch.php and lpextras.php) that should fix this particular error:


    Note that I don’t use LiveJournal so can’t test this, but the mod is quite minor and doesn’t affect the rest of the plugin’s workings.

    Now I’m getting the error message…

    Warning: array_values(): The argument should be an array in /home3/trench/public_html/wp-content/plugins/LivePress/lpextras.php on line 130

    Thanks Kaf – My posting page is loading… The only problem is that after the “LJ Extras” title, the usual menu is missing. Anyone have any luck with this?

    I used the method posted by theglobalguy in the original Upgrade thread:

    I just fixed it another route by copying the function get_currentuserinfo() and get_userdatabylogin() from pluggable-functions.php to functions.php.

    Works perfectly for me.

    That fixed it. Thanks for posting it here Jenn!

    1.5.1 broke a few plugins (including mine) which depend upon the functions declared in pluggable-functions.php. Here are the instructions for developers affected by this change: http://fortes.com/2005/05/14/updating-wordpress-plugins-for-151

    Worked for me, thanks!

    I’ve tried the fix file and unfortunately I’m still not synching w/ LJ.

    Right now Everything looks fine, LJ-cuts and user tags work, and my mood and music are showing up on my site, but I hit update, and my site updates, but LJ doesn’t.

    Does anyone know how to see errors outputed by livejournal?? Currently wordpress just gives me a “site updated” message and appears back a post screen.

    I had it working before the upgrade to 1.5.1

    Any help would be greatly appreciated….this is a great plugin, and I miss it right now.

    If there is a LivePress error, it generally outputs to a custom field (unt_lp_error, I think). On the post edit screen, scroll to the bottom and see if you see any errors in the custom fields.

    Thanks for the feedback.

    But, I have no unt_lp_error, or any other custom field resembling an error.

    For reference my blog is at
    and my LJ username is BigCat2k

    Someone took pity on me in #wordpress and fixed LivePress so it works in 1.5.1. You can get it here: http://www.everytomorrow.org/LivePress-1.5.1.zip. I can’t really support it since I didn’t write it (and the guy who helped fix it doesn’t really want to support it either) however, he did give me the okay to release it… and I have tested, so it works. Enjoy.

    Thanks Nikki!! I can’t wait to get this working again!


    yeah, thanks a lot…I see how the author managed to fix this.

    Unfortunately for me, I still can’t seem to get it to work.

    Everything seems to look OK, and the post seems to publish, but when it returns, it comes back without the field unt_lj_entry filled in.

    I’m confused about this, and it is driving me crazy….Any help anyone can give me would be greatly appreciated.

    I’m still getting errors too.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘LivePress 1.5.1 issue’ is closed to new replies.