Support » Plugin: Livemesh Addons for Elementor Page Builder » Livemesh crashes site when Polylang is activated

  • Resolved grumix

    (@grumix)


    Hello!
    I ran into a problem when I added Polylang plugin to my website.
    When I tried to edit my homepage with Elementor it showed me that there has been an error and there is a e-mail sent out to my e-mail address. So I opened it up and wordpress tells me that it was Livemesh that caused the crash. And while Polylang plugin is active the homepage is not accessible to anyone, from every browser it says that here has been an error. As long the Polylang plugin is active this problem persists.

    Have anyone else had this kind of problem, if so, please let me know how to resolve it.

    Thank you in advance! πŸ™‚

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author livemesh

    (@livemesh)

    I see that the error raised is –
    ​
    ​ Fatal error: Cannot redeclare icl_register_string() (previously declared in /Applications/MAMP/htdocs/buildtest/wp-content/plugins/polylang/modules/wpml/wpml-legacy-api.php:251) in /Applications/MAMP/htdocs/buildtest/wp-content/plugins/wpml-string-translation/inc/functions.php on line 206
    ​
    ​is due to a conflict of Polylang with WPML. This has been documented before and you can Google for few solutions posted online or contact Polylang support to resolve this.
    ​
    ​If you have not activated WPML, can you pls provide the error seen on your site error log?

    Plugin Author livemesh

    (@livemesh)

    Based on the error log provided by you, we have released an update today which we hope will help address this issue.

    Hi there!

    I am getting the below error when i am trying to access an page under en/ using polylang
    Just updated to the latest version on polylang and wordpress.

    Uncaught TypeError: $(…).livemeshWaypoint is not a function
    at HTMLDocument.<anonymous> (odometer.min.js?ver=2.5.6:1)
    at i (jquery.js?ver=1.12.4-wp:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:2)
    at Function.ready (jquery.js?ver=1.12.4-wp:2)
    at HTMLDocument.J (jquery.js?ver=1.12.4-wp:2)

    Is a known error and there is a fix or something else should be done?
    thanks!

    • This reply was modified 1 month, 2 weeks ago by pskiadas.
    Plugin Author livemesh

    (@livemesh)

    Can I get a link to the page where this is happening? Looks like a particular JS file of our plugin is not loaded on the page.

    Plugin Author livemesh

    (@livemesh)

    BTW, the previous update fixed the problem originally reported, as confirmed by @grumix to us.

    Hi again!

    https://dancecentre.akropoditi.com/en/events-en/

    this is the link.The problem is still there for me.
    Could you please check and let me know?

    Thanks in advance!

    • This reply was modified 1 month, 2 weeks ago by pskiadas.

    The above link should be down for a while as it still under development.

    Plugin Author livemesh

    (@livemesh)

    Maybe you can use our contact form on our website https://livemeshelementor.com to send us temp credentials to your site. That will help us debug this issue.

    The page linked by you seems to have moved or got deleted and I see that it does not exist.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.