Support » Plugin: Comments - wpDiscuz » Live Update not updating live inline

  • Resolved Satan81

    (@satan81)


    Hello! I’ve installed and configured wpDiscuz, but the Live Update feature isn’t updating the comment thread. I have to reload the page in order to see new comments. Is there a setting I’m missing?

    Our environment:

    WordPress 4.4.2 running Mantra theme.

    Active Plugins:
    Akismet
    BuddyPress
    Customify
    Limit Login Attempts
    SI CAPTCHA Anti-Spam
    The Events Calendar
    Theme My Login
    Theme Tweaker
    wpDiscuz

    Comments -> WPDISCUZ -> Settings -> Live Update
    – Always check for new comments and update automatically (checked)
    – Disable live update for guests (not checked)
    – Update comment list every: 1 minute

    Refresh comment optimization button clicked multiple times.

    Settings -> Discussion
    – Enable threaded (nested comments): 8 levels deep (checked)

    URL: http://bobbytobergy.com/wp/2016/02/03/new-test-post-for-trying-out-stuff/

    https://wordpress.org/plugins/wpdiscuz/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Satan81

    (@satan81)

    An update on this:

    I switched from “Always check for new comments and update automatically” to “Always check for new comments and show update buttons”.

    The update buttons do appear as expected, such as “1 new reply on your comment” and “2 new comments”. However, when I click the button, I see the animated status bar thing, but the comments don’t load.

    Oh, and I’m using wpDiscuz – Supercharged native comments version 3.2.5.

    Plugin Author gVectors Team

    (@gvectors-team)

    We’re currently checking this issue, I’ll update this topic soon.

    Satan81

    (@satan81)

    Update:

    I disabled BuddyPress and live comments are working _almost_ normally. The new comments appear on the page as the update interval triggers.

    However, new comments don’t have the “Reply” option unless the page is reloaded.

    Plugin Author gVectors Team

    (@gvectors-team)

    To display reply buttons for guests, you should set these option like on screenshot: http://screencast.com/t/WUaRcSEa

    – Users must be registered and logged in to comment [unchecked]
    – [checked] Enable threaded (nested) comments [more than 1]

    Satan81

    (@satan81)

    First item is unchecked.
    Second item is set to 8.

    Reply button still not present when new comments appear.

    http://bobbytobergy.com/wp/2016/02/08/morning-free-association-282016/

    Satan81

    (@satan81)

    Aha. I had the Reply button hidden for guests, so it’s now unhidden. This is odd, because we’re all logged into our accounts, yet the comment options think we’re guests when new comments arrive.

    At any rate, we’re getting into problem creep here. Let’s consider the original issue resolved, and I’ll read through your forums to resolve the Reply button issue.

    Many thanks for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Live Update not updating live inline’ is closed to new replies.