Support » Plugin: Wordfence Security - Firewall & Malware Scan » Live traffic problem – Wordfence showing unkown location

  • Resolved wordpressuser650

    (@wordpressuser650)


    Up until a couple of days ago, Wordfence live traffic was showing the location of every hit to my site. Now it is showing unknown location on every hit.

    Even the live traffic from past weeks and months (that I know were displaying the location correctly) are also now showing unknonw location.

    I have the latest version of wordpress version 4.9.4, and wordfence (Version 7.1.0).

    I would be so grateful if can anyone advise how to resolve this.

    Many thanks in advance

Viewing 15 replies - 1 through 15 (of 23 total)
  • Although this doesn’t address any problems with Wordfence, I’d suggest installing the WP Fail2Ban Redux plugin and grepping your authorization log file (/var/log/auth.log on my system) for failed and/or successful login attempts. “Hits”, as in accesses to your site site URL regardless of login attempts can be found in your web server log file(s), the location of which are determined by the server’s configuration.

    I have the same issue, started the same time as yours

    Hi. I also have problem with live traffic – all location are unspecified. Furthermore scan function stopped working. I get this error “Call to Wordfence API to resolve IPs failed: There was an error connecting to the Wordfence scanning servers: cURL error 35: Unknown SSL protocol error in connection to noc1.wordfence.com:443” In diagnostic tab all option is green except one option: Connecting to Wordfence servers (https) –
    wp_remote_post() test to noc1.wordfence.com failed! Response was: cURL error 35: Unknown SSL protocol error in connection to noc1.wordfence.com:443

    I try to check / uncheck this two option “Start all scans remotely (Try this if your scans aren’t starting and your site is publicly accessible)” and “Enable SSL Verification (Disable this if you are consistently unable to connect to the Wordfence servers.)” but problem with scan and live traffic still occur. Last successful scan was Mar 13 08:41:57. I contacted the support of my server and they told me that they do not block the server noc1.wordfence.com. I also check on my server admin panel that geolocation is working. My wordpress version is 4.9.4 and wordfence is 7.1.0.

    Just an FYI, still working for me here, I’d imagine that for some reason your Wordfence install is not able to connect to the Wordfence servers.

    This could be useful:
    https://www.wordfence.com/help/tools/diagnostics/

    MTN

    Connecting to Wordfence servers (http) is ok, but Connecting to Wordfence servers (https) is fail. It’s some SSL problem. I used this option (Disable SSL Verification and Enable Start all scans remotely) in diagnostics tab but doesn’t help. All worked good to 14 march.

    I have exactly the same problem as described by scope33, with the same symptoms (unknown locations in “live traffic” window, scan failures) and since the same day!
    So this seems to be definitively a wordfence issue. I posted a ticket via the premium forum, and I’m waiting for an answer.

    any updates about this ? i have the same issue since a couple of days

    Still waiting for an answer.
    Knowing that other people are in the same situation, since the same day, is not a consolation. It is a source of frustration. The biggest problem is not the “unknown location” thing, it’s the fact scans are impossible. And THIS is a serious thing, espcially for a paying user who is concerned by security issues.

    If you are a Premium user you should submit a support ticket for this… WF support is very responsive.

    @bluebearmedia
    Yes, that’s what I said, and what I did.
    Indeed they answered me today, and gave me the answer.

    @scope33
    Since we had the same problem, this is an excerpt of Phil’s answer:
    “Thank you for sending the dagnostics report. I see that the server is running a very old version of the cURL library – 7.21.0
    Can you ask your hosting provider to upgrade to an up-to-date version and see if that solves the scan issue for you.”
    I went to my site manager (the site is hosted by OVH), and was able to update my configuration (from “legacy” to “stable”).
    And everything works nicely (for example, the cURL library is now 7.38.0).

    Hi. Thanks to Jean-Michel Ferrard – problem is solved. I changed my configuration on server and now scan and live traffic work ok. Now my cURL library is 7.38.0

    @scope33

    can you please tell us how we can update the cURL please ?

    You must search in admin panel of your host provider for option php update or cURL update. In my admin panel I only change php configuration from “legacy” to “stable” and cURL version was change to version 7.38.0.

    Hi @wordpressuser650
    If you are still running into this issue, please go to (Wordfence > Tools => Diagnostics) and click on “Send Report by Email” button at the top of the page, you can send the report to “alaa [at] wordfence [dot] com”, make sure to include your forum username, I will take a look at this report and let you know my findings.

    Thanks.

    I starting seeing this problem about the same time as the OP on SOME of the sites I have Wordfence installed on. On other sites I’m not seeing the problem.

    Turns out that the server on which I am NOT seeing the problem are all running libcurl 7.38.0. The server on which I AM seeing the problem is running (heaven forbid) 7.15.15!

    However, my hosting company swears they haven’t recently “downgraded” libcurl on the server where I’m seeing the problem.

    Is there any chance that one of the recent updates to Wordfence changed something so that it is sensitive to the version of libcurl?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Live traffic problem – Wordfence showing unkown location’ is closed to new replies.