Acunetix WP Security
[resolved] Live Traffic heavily impacts SQL size (4 posts)

  1. AlexD72
    Posted 1 year ago #


    I've noticed that my SQL table "wsd_plugin_live_traffic" has grown up to 50Mb.

    It seems that setting option "Maximum number of entries to store for Live Traffic" doesn't work. I've tried to put zero there or any other small numbers but it stores thousand of records anyway.

    Tried with WP 3.6.1 and 3.7



  2. Acunetix
    Plugin Author

    Posted 1 year ago #

    Hello, AlexD72

    thank you for letting us know about this issue. We are currently working on releasing the new 4.0.2 version of the plugin which will fix this.

    Can you please let us know whether or not cron is enabled on your wordpress installation?

    Thank you


  3. AlexD72
    Posted 1 year ago #

    Hello, Costin

    Thank you for reply. Cron is enabled. At least I can add cron task in the DirectAdmin Control Panel of my web hosting.


  4. Acunetix
    Plugin Author

    Posted 1 year ago #

    Hello, Alex

    Thank you for your reply.

    I see that cron is enabled on your server, but I was interested to know if cron is enabled in your WordPress installation.

    As regarding the live traffic tool, with the latest update of the plugin, version 4.0.3, there is a background cron job that will be run every hour and it will clean up the extra entries from the live traffic table.

    For this to work, it needs cron enabled on your WordPress installation. If cron is disabled, you can always use the "delete all" button from the live traffic page to delete all entries from the table.

    Also, if this tool generates too much load on your database, we have added a setting in the settings page which you can use to disable the live traffic tool.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Acunetix WP Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic