• Resolved hubitgr

    (@hubitgr)


    Hello,

    I recently added the plugin to a new site.

    Everything works fine except live stream. I followed the instructions for api key, but on google console shows errors on authentication.

    Is there a solution for this problem?

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author embedplus

    (@embedplus)

    Hi,

    What errors are you seeing? Also, what happens if you try embedding this channel’s livestream on your site: https://www.youtube.com/channel/UCLA_DiR1FfKNvjuUpBHmylQ
    This channel is running a livestream 24-7 so it should show. Please send a link after.

    Also, what channel’s livestream are you trying to embed?

    [ Signature deleted ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.
    Thread Starter hubitgr

    (@hubitgr)

    Hi again,

    I replaced the link and still not working.
    In google console I see that I have reached my daily limit.
    I am trying to embed the following channel.

    https://www.youtube.com/embed?live=1&channel=UC734pewJd6HfqpGrkZmllmQ

    Plugin Author embedplus

    (@embedplus)

    Hi,

    If you’ve reached your daily limit then you won’t be able to get anything to work since it means that Google/YouTube won’t send the plugin any data. It turns out, however, that the reason you’re getting your daily limit is probably due to a bug that YouTube’s API is currently having. Right now, we suggest you star this particular bug that has been filed to Google/YouTube: https://issuetracker.google.com/issues/122670557

    While they are fixing it, you might get some success by creating a totally new Project in the Google Console and then create a new YouTube API key within that new Project — then replace your old key in the plugin with the new one just generated.

    Thread Starter hubitgr

    (@hubitgr)

    Hello again,

    Is there any posibility that this happens because my channel has not Monetization enabled?

    Thread Starter hubitgr

    (@hubitgr)

    Actually I found something. If there is already a live stream, evertything works fine.
    If there is no stream available repeats the div that is hown many times and after a few seconds shows that my quote is full.
    I think that it must be plugin ‘s error on youtube error call from api.

    Plugin Author embedplus

    (@embedplus)

    Hi,

    Right now your site is behind a coming soon page, so we can evaluate this page:
    https://kalamatatv.com/live/

    Can you elaborate on what you mean by “repeat div”? Perhaps even provide some screenshots since we can’t see the actual page yet.

    [ Signature deleted ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.
    Thread Starter hubitgr

    (@hubitgr)

    Hello,

    The following print screen shows the title LIVE twice which happens when there is no live feed form youtube. It should show the message that I have set from plugins options. When this error shown My account quote is full.

    https://prnt.sc/mf4353

    On the following printscreen you will see that everything works fine when there is live feed.

    https://prnt.sc/mf43bj

    Plugin Author embedplus

    (@embedplus)

    Can you provide:

    1) the exact embed code that was pasted, e.g. [embedyt]…[/embedyt]
    2) what happens after creating a brand new API server key with no restrictions.

    [ Signature deleted ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.
    Thread Starter hubitgr

    (@hubitgr)

    I found the error. Probably is wordpress error. If I replace the following line at 2362 in youtube.php

    return apply_filters(‘the_content’, wp_kses_post(self::$alloptions[self::$opt_not_live_content]));

    with

    return wp_kses_post(self::$alloptions[self::$opt_not_live_content]);

    Everything works fine. I noticed that the function apply_filters was responsible for continuous class to youtube api. I didn’t find why this happens, but it solved my problem.

    Plugin Author embedplus

    (@embedplus)

    Please let us know what you have/had placed in the “Default Not Live Content” box in the plugin’s settings page. Simply paste it exactly as you had it there in a reply?

    [ Signature deleted ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.
    Thread Starter hubitgr

    (@hubitgr)

    Unfortunately I changed the content.
    It was saying:
    Δεν υπάρχει ζωντανή μετάδοση αυτή τη στιγμή.

    Plugin Author embedplus

    (@embedplus)

    Regarding the quota issue, YouTube/Google has changed their quota limits in the past and that might have affected you. You should request for a quota increase using the form here:
    https://docs.google.com/forms/d/e/1FAIpQLSd5HxReFtxATJLNfLwQiucfQwYL295Xemgc6nhFXo1vcitg3A/viewform

    You might also get some benefit by using a caching plugin or activating the plugin’s own caching if you have that feature enabled.

    [ Signature deleted ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Live stream not working’ is closed to new replies.