WordPress.org

Support

Support » Multisite » Live Preview in WP 3.4 Multisite not working

Live Preview in WP 3.4 Multisite not working

  • I upgraded from WP 3.3.2 to WP 3.4 in my Multisite (path) environment. Now I realised, that the live preview of themes doesn’t work. When trying to do the live preview, I get a sidebar left and a blank main section.

    On another WP 3.4 installation (single) it’s working fine. So no error from Firefox.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 44 total)
  • Doesn’t work for me, either; also multisite. Could they have shipped this without ever testing it in multisite mode?

    Live Preview does not work for me either, this is rather frustrating as I have a client waiting for their site.

    Neither the custom theme I built or the two basic themes that were the default install work. I can see the thumbnail for all three, but if I go to live preview. I only see the left sidebar and a blank preview area.

    I have tried three different browsers, same issue across the board. I am running win7 home premium.

    I will confirm that live preview works in the base domain of the multisite install. For example, all my domains are based upon http://mypencil.net, and the live preview works there. It does not work on any of the subdomains (http://glenc.co, http://broadpool.com), however.

    I had thought that it might disagree with the domain mapping pluging, but disabling that did not change the behavior.

    IE/Chrome/Ffox. Constant reloads on my multisite MAIN site, but works on my subsites..

    @gecampbell: You’re right, same behaviour here. I hope this will be fixed soon by the programmers.

    yes,is this the problem.
    I use plugin Enable Multi-Site, and subsite give maintenance page.

    This is NOT fixed in WordPress 3.4.1, sadly.

    when and where I can know if the problem of multi site is fixed?

    I use this plugin : Enable multi site

    I finally figured out how to create a bug/ticket, so here’s the one to track this issue:
    http://core.trac.wordpress.org/ticket/21235

    I searched the existing database, and it doesn’t appear that anyone else has reported it.

    Moving this to the Multisite subforum.

    I can’t reproduce this one, it’s working fine for me on a mapped domain and a subdomain. I went to another site and it’s working on a subfolder install. (Tested on sites without any plugins and with a ton of plugins, with Genesis/Theme Hybrid and TwentyEleven).

    I don’t think it’s a bug with Multisite, but it may be one with plugins or themes.

    So. Have y’all tried turning off plugins and switching to the default (twentyeleven) theme on these subsites? Also what network wide plugins are you running?

    Well, it’s 100% reproducible on my system. I have tried with a dozen or so different themes and I’ve turned off the WordPress MU Domain Mapping plugin (that was the obvious one). Other plugins I have installed:

    Akismet
    bbPress
    Disable Comments
    Disqus Comment System
    Facebook (not currently used, but still installed)
    FD Footnotes
    Google XML Sitemaps (4.0beta1)
    Jetpack
    MapPress
    Markdown on Save Improved
    MediaRSS
    Podcasting Plugin by TSG
    Publish Confirmation (this was installed recently, after the 3.4 and 3.4.1 upgrade)
    Search & Replace
    Syntax Highlighter ComPress
    WordPress Importer
    WP Minify
    WPtouch
    WSA Favicon
    YOURLS: WordPress to Twitter

    gecampbell – I suspect it’s too much to ask that you turn off all your plugins, eh? 😉

    How about this. Can you install a second instance of Multisite on your server (in a subfolder), with no plugins and the default theme? Then see if you can reproduce it.

    ETA: I use these plugins, without issues:
    Akismet
    bbPress
    Jetpack
    WordPress Importer
    WPtouch
    YOURLS: WordPress to Twitter

    And WPMU Domain mapping and a host of others.

    Actually, I’ve gone through and turned off about 80% of them, but your suggestion is a good one. I’ll see if I can do that.

    Ok, I have a new site set up at http://xlerb.com but I haven’t enabled multisite yet. Need to find the docs on that again :/

    Ok, new child site at http://a.xlerb.com and Live Preview DOES work now. I presume that the next step is to add plugins one at a time and see which one breaks it?

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Live Preview in WP 3.4 Multisite not working’ is closed to new replies.
Skip to toolbar