Support » Localhost Installs » Live Preview (Customizer) Not working

  • Hi. I am COMPLETELY new using WP so when I say this is what I did, and if someone can help, PLEASE do so in a step-by-step reply. (Thanks).

    I first installed MAMP on my Windows 8.1 PC. Then, I created the database on the local server (per the directions). I unzipped the latest WP version to the ‘.htdocs’ folder and then installed WP – everything worked fine and I logged in using the latest version of Chrome Browser.

    From the Dashboard, when I click ‘Customize Your Site’ the frame opens and the default site (Twenty Seventeen) displays with little blue circles with pencil icons next to where you can make edits.

    HOWEVER, if I click on ‘or, change your site completely’ from the Dashboard, the default site flashes for a second, disappears, and then all three of the default sites (thumbnails) show in the right frame (Twenty Fifteen, Twenty Sixteen, and Twenty Seventeen). Twenty Seventeen has a button that says ‘Customize’ and the other two have one that says ‘Live Preview’. When I click ‘Live Preview’ the page says loading for a couple of seconds and then goes right back to displaying all three thumbnails – only this time the one I clicked on to preview says ‘Customize’ and the others say ‘Live Preview’. So, if I click on the other site that now says ‘Live Preview’ I get the same little pencil icons (are they supposed to be there?).

    Can someone PLEASE tell me why I can’t see a live preview and / or how to resolve this? I have NO PLUGINS installed – this happened right from the start. I’ve reinstalled WP and MAMP, performed a system restore and reinstalled, and created new databases – nothing has worked.

    Please help. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve tried to troubleshoot myself and have found that any version of WP about 4.8.5 is when the issues starts. So, right now I have 4.8.5 installed on my local server. I don’t know if this makes a lot of difference since I’m only editing / customizing before uploading to my hosting account.

    This isn’t resolved. 🙁

    So if anyone has ideas, please let me know.

    The customizer in WordPress has serious issues with Content Security Policy, and the newest release of Chrome is pretty strict with the “frame-ancestors” policy. I’m sure that’s why you don’t see the live preview — you can verify this by pressing Ctrl-Shift-I to bring up the Chrome dev tools, and then click the console tab. Now try to load the customizer. I’ll bet you get a CSP error about frame ancestors.

    (I’ll bet we see some code in an upcoming WordPress release that disables CSP on the backend.)

    Instead of through the customizer, you will have a better time changing themes etc through the old path: Dashboard > Appearance > Themes and so on.
    Or you could change to a different browser.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.