Support » Fixing WordPress » Live preview and customizer not working

  • I am building a new website hosted by fatcow.com and have downloaded wordpress to my hosting site. Having then logged into wordpress I have installed and activated the default 2015 theme but cannot get the customizer (or the live preview) to work. It loads the menu to the left but on the right of the screen it is just grey with a little loading symbol. I haven’t yet managed to even start building my website as I cannot get to customize my theme…..

    I have followed the advice in various threads and deactivated all my plugins as suggested, cleared my cache and browsing histories but none of these actions have worked.

    What should I try next? Is this a wordpress issue or a problem with my hosting site?

    Thanks for any help you can suggest.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you tried previewing the Twenty Fourteen theme?

    Yes, it does exactly the same – not loading any live previews.

    Have you tried re-installing WordPress 4.2.2 in the updates page?

    Yes I did that and it didn’t make any difference, still not loading…..

    I have the same problem. Can’t customize any theme.

    I need to correct a few thing on the site so I was considering downgrading WP then upgrading it when I finish.

    Same problem here too! Since dl-ing 4.2.2 I cannot preview site either by “visit site” or by “customise” Everything is up to date, all plugins disabled, tried in two browsers, re-installed WP…. tried everything! At least it’s not just me & this is obviously a WP issue which needs sorting asap as right now WP is rendered useless to me.

    In the end I contacted my hosting company who were able to sort out the issue for me – it was the way in which WordPress was saved in my file manager on my hosting site. They were able to put everything in the correct place and it’s been working fine ever since.

    Thanks I will give them a call tomorrow!

    I resolved this by myself, I’ll write step-by-step how, since I see this is a common problem. It was a problem with a plugin.

    -Disabling plugins using Dashboard didn’t help much, so on the server I renamed plugins in wp-content to plugins-old (or whatever). This disabled all plugins on the site, but preseved the settings. After that the customizer worked fine.

    -I created new plugins directory in wp-content.

    -I moved directories (plugins) from plugins-old to plugins one by one, and as I activated the plugin I moved, I checked does the customizer work.

    The problematic plugin was wp-super-cache. As soon as I moved it out of plugins directory, customizer started working again.

    Because I have been using a theme which allows users to configure it using its own pages, I haven’t been using the theme customizer at all, so I don’t know if it ever worked previously. Because WordPress is going to require theme developers to use the customizer, I thought I should try it out on some new themes on a copy of our site that sits on a development machine. When I did so, the live preview behaved as described by AllieSackett: a loading symbol would forever spin.

    Here’s what I have tried so far without luck:

    • Disabling all plugins
    • Remvoing the entire plugins directory as described by alc000 above
    • Switching to a different web browser that has no installed extensions
    • Changing the wp-theme (and its subdirectories), so their group membership is “www-data” and changing the group permissions for those directories to read, write, and execute
    • Modifying wp-config.php by changing define('DISALLOW_FILE_EDIT',true); to be false.
    • Changing my .htaccess file to allow access to wp-config.php
    • Since I used svn to install WordPress core at my site, and continue to use it to update the core installation, I tried using svn again to reinstall the core; it said I was at the current revision. So I tried going back to a previous revision (4.1) updated the database, then switched back to the current revision (4.2.2) and updated the WordPress database again. I now had a fresh install of the WordPress core. Without enabling any plugins, I tested the live preview.

    Nothing worked. I mention in passing that at one point in time I tried wp-super-cache, but it was disabled and its directory was removed long ago.

    @debplatt – I have the same no live preview issue too for almost a week. I have done everything you have done and I have contacted my site host as well. They looked at all my WordPress files and said they were all in the proper place. I have deleted and re-installed everything multiple times, tried different browsers, deactivated and moved plugins, and on and on. Nothing is working, need help fast!

    I have the same issue, no preveiw either at almost every browser, different server. I know this is not help but just I felt I’m not alone then.

    I resolved my issue, hope it works for those still suffering! The problem for me was that my old site, thru HostMonster, and an index.html file still stored in my cPanel – File Manager. All I had to do was change the document title from index.html to index.php, and voila! Customize Loading problem solved.

    I finally found the solution from another forum post here, scroll to bottom:

    https://wordpress.org/support/topic/cant-preview-or-customize-themes-keeps-trying-to-load

    @alexisglenn, I was delighted to hear that you resolved your issue. As it turns out I am accessing my site by logging on directly using a terminal, and not via cPanel. And my installation directory just had an index.php file without there being any index.html. So I am still out of luck. But as I said, I’m glad that other people are successfully resolving this issue. But as for me, I’m still stumped.

    Moderator t-p

    (@t-p)

    Except the OP, everybody else who still need help, as per the Forum Welcome, please post your own topic. That way you stand a good chance of getting full attention to your specific issue. Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, accounts, hosts, plugins, theme, configurations, etc. Thus one problem, on one setup is not indicative of the functionality and reliability of an application as a whole.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Live preview and customizer not working’ is closed to new replies.