WordPress.org

Support

Support » Plugins and Hacks » [Live Blogging] Auto-updating not occuring

[Live Blogging] Auto-updating not occuring

  • Hello.

    I’m trying to setup the Live Blogging plugin on my WordPress site. Everything works fine, but auto-updating doesn’t work. For example, I’ll publish an update and wait five minutes for the update to automatically appear in the live blog. It doesn’t.

    If I refresh the page, the update is there.

    Any ideas/thoughts?

    Thanks.

Viewing 15 replies - 16 through 30 (of 31 total)
  • I just uploaded it to anyhub.net (a free file hosting service) but their server seems to be reeeeally slow. here’s the link:
    http://anyhub.net/file/3xwD-live-blogging-2.1.7_updated_for_wordpress3.2.1.zip

    If you have a suggestion of somewhere better to host it, or if you want me to email it to you instead, I can do that.

    Thanks for uploading, but live blogging still doesn’t work for me…

    hmm. I just deactivated and deleted live blogging and installed it again from the folder I uploaded, and it’s working for me.

    I assume, you have created a normal blog post, added the [liveblog] tag to it where you want your post to show up, and checked “Enable live blogging on this post” at the bottom right?

    Yep, I’m doing exactly that. Tried it on an older post that I used a live blog on and still didn’t work.

    I have a DB caching tool enabled…could that be it?

    I’d try disabling that (if possible) and all other plugins just to see if you can figure out what’s causing the problem. Sorry it’s not working for you. I wish I could help you get it working. I was pretty happy that I was able to get it working on my wordpress 3.2.1 install.

    do you happen to have firefox with firebug installed so you can see if you are sending/receiving the polling requests from the server at all? If not, would you mind sharing your blog url so I can take a look? (just out of curiosity)

    Just deactivated all of my plugins and re-enabled them all. Live updating works now. Weird – something must have been cached or something?

    But anyways, thanks all the help!

    Back to hosting the file, MediaFire might be a little better.

    Awesome buddybonesbones, thanks – btw, the code is on Github here: https://github.com/cnorthwood/liveblogging if you wanted to fork and issue a pull request with the changes

    Did you test it chris? I just want to confirm that it worked for someone else other than just me. 🙂

    not yet 🙁 am pretty busy atm I’m afraid

    I hadn’t noticed the post about it working for itsalltech1 until now. 🙂 Makes me happy. Glad someone else could use my update.

    That fix didn’t work for me, but after investigating I found it was caused by the fact that I was forcing SSL on the admin, and this caused a problem with cross-site http requests since my whole site doesn’t default to SSL.

    buddybonesbones’ modified version of this plugin works for me.

    And it looks like Chris is making these fixes: http://plugins.trac.wordpress.org/log/live-blogging/

    just a short feedback: the modified version works for me.
    – WordPress 3.2.1
    – Twenty-Eleven theme (as a basis, but modified)

    what i did:

    – edited comments.php so there is an <ol id=”commentlist” class=”commentlist”> (there was only a class of this name before, no ID)

    – edited functions php with this:

    add_filter('live_blogging_build_comments', 'twentyeleven_liveblogging_comments');
    function twentyeleven_liveblogging_comments($a)
    {
        $a['callback'] = 'twentyeleven_comment';
        return $a;
    }

    though i’m not sure it is needed or works – will try to remove it again.

    until this point, id did not work.
    – I installed the version of buddybonesbones with no further modifications to the theme or plugin -> now it works.

    A bit more on this. Even after your update budybones bones, mine wasn’t auto updating, or so I thought.

    The CSS of new posts coming in wasn’t changing from “display: none; position: absolute; opacity: 0” meaning it simply wasn’t showing up.

    It’s supposed to animate in the nice new post, but it just wasn’t changing so I changed your JS make the style be ‘block’ and on line 69 I changed it to: jQuery(div_id).fadeTo(0, 1,

    Thanks buddybonesbones you mod works great.

    the only issue I know appear to have is image placement when viewed in chrome but I’m sure I can handle that with a little css tweaking.

    thanks again

    Kevin

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘[Live Blogging] Auto-updating not occuring’ is closed to new replies.