Support » Plugin: Amelia - Events & Appointments Booking Calendar » Live and Die with Amelia

  • Unless you know you want to live and die with Amelia, avoid it. Amelia was more than I needed. When I eliminated the plugin, it left 37 files in my SQL database that are difficult to near impossible to remove. I tried using WP-Optimize – Clean, Compress, Cache to delete the database files from my database it failed. When I upload a backed-up SQL database to resolve the problem, it also failed. The same 37 database entries keep reappearing.

    When I requested help to resolve this on-going problem, this was the company’s response.
    “You will just need to delete all of it manually, all the tables that contain ameliabooking.

    Have a nice day,

    Amelia Booking can have a nice day too but without me. Finally, I found and used Advanced Database Cleaner and it solved the problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ameliabooking

    (@ameliabooking)

    Hi,

    Thanks for your opinion.

    There’s a simple reason why it is like that, it is very important for our users not to remove their data stored in the plugin by mistake. Many WP plugins manage this this way, since it’s safer for users. We are sorry that you had troubles deleting the tables, with bulk option it can be done easily. All the database tables have ‘amelia’ prefix in it so it is obvious for users what they need to delete if they want to erase all Amelia tables.
    We certainly plan to add a checkbox option to the settings very soon, so the users will be able to choose whether they want to delete all tables during the uninstall process.

    Have a great day.

    I’d like to add its not only tables, its also a lot of user roles as well, major pain in the butt….

    I am trying to manually delete the amelia tables from the db – but keep getting an error about not being able to delete or update a parent row.

    Has this issue been resolved? I have a ton of tables from when I had the plugins installed months ago and now realizing it is probably causing backup issues I am having.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this review.