Support » Plugin: WP Easy Pay - With Square » “Live account” not working, only seeing “test account”.

  • Resolved caitlindev


    I just installed this plugin and set up a new free Square account. When I go to the WP Easy Pay Settings page in wp-admin, the toggle between “Test” mode and “Live” mode doesn’t do anything. I only see form fields asking for “Test” API credentials, nowhere to put the “Live” ones. Any help with this would be amazing, thank you for reading.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author


    Hi @caitlindev,

    Thank you for contacting us, kindly click the connect to square button for live transactions and select the mode as live click test mode for test transactions and manual input of api credentials would appear for sandbox.

    Thank You!

    • This reply was modified 4 months, 2 weeks ago by

    I did click the button “Connect to Square” button. I also did click the toggle button to “Live”. I’m still only seeing the “test account” form fields in this plugin’s settings page. I wish I could send you guys a screenshot to see what I’m talking about.

    But I went ahead and just entered my live/non-sandbox API credentials in the “test account” form fields in the plugin and it seems to be processing live transactions just fine.

    Plugin Author


    Hi @caitlindev,

    That is not an issue it’s like if you want to use live then press connect button and test fields also remain there as when you want to use test field you just have to change the mode to test and enter the test app id and test client id in the fields. If you have connected the button then no need to enter anything in the test fields as the live mode is already connected. We did this change for the easiness of users so that on one click they can connect live with square.

    Hope you would understand this and do let us know if you have any other queries.


Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.