Support » Plugin: LiteSpeed Cache » LiteSpeed underperforming

  • Resolved fneuf

    (@fneuf)


    Hello,

    I have an original situation to report. I’ve been setting up a fresh 5.0.4 site with o2switch host, and Twenty Seventeen theme. Came the time of optimization. For that task i I selected latest versions of :

    • FVM
    • aSync Javascript
    • LiteSpeed Plugin
    • Server’s LiteSpeed
    • Server’s PageSpeed mod

    After some tweaking I obtained results satisfying me :

    1. GTmetrix : PSpeed 92 / YSlow 86 / 1.7s / 20 requests
    2. Pingdom : B 84 / 614ms / 22 requests
    3. PSI : 100 86

    I added WP-optimize to get rid of drafts and such. Continued to work. Feeling lucky I later migrated to WP 5.1.1. Testing the website I identified an error with captcha in Contact Form 7, corrected it thanks to Hai.

    Then I realised the correction was not consistent. It was ok in Admin and an unrelated laptop. But every other device was still preventing the usage of the form. From that point, it’s became a wreck. I started to investigate more deeply and also realized perf were “bad”, like there were not anymore any optimization. I tried to revert my last changed settings. No success. As time passed I went to bigger and bigger solutions. Reading more and more faq, docs. Some of the multiple things tried:

    1. Flush cache
    2. Change some parameters (plugs+ pagemod)
    3. Defaulting parameters
    4. Delete plugins
    5. Reinstall plugin
    6. Switched FVM to Autoptimize
    7. Unactivate LScache on server level
    8. Restored a backup from a known safe point.

    At each step in the process I ran benchmarks. Not a thing I tried did made a difference. Benchs were constantly low. At some point I realized that the only logical cause to such ehavior was I had some kind of caching issue. Furthermore, updates made to the content of my website were not seen online. Whatever the device, browser and state of browser cache.

    With no more ideas on my side I contacted my host support. Long story short, in the end they deactivated LScache (server and plugin, supposedly just like I did) themselves and content on the site again refreshed. Performance were also back to a normal, acceptable, level.

    I’ve since tried to reactivate the whole LS cache and again, perf are still lowered, even as if not as bad as before. Right now :

    LS OFF :

    • GTmetrix : 94 / 85 / 3.3s / 487kb / 25 requests
    • Pingdom : B 82 / 580kb / 2.1s / 28 requests
    • PSI : 97 / 66

    LS ON :

    • GTmetrix : 87 / 76 / 3s / 807kb / 46 requests
    • Pingdom : C 70 / 1Mb / 1s / 48 requests
    • PSI : 94 / 54

    What could be the source of this underperforming situation and what should I check to correct it?

    • This topic was modified 1 year, 3 months ago by fneuf.
    • This topic was modified 1 year, 3 months ago by Steven Stern (sterndata).
    • This topic was modified 1 year, 3 months ago by fneuf.
    • This topic was modified 1 year, 3 months ago by fneuf.

    The page I need help with: [log in to see the link]

Viewing 16 replies (of 16 total)
  • Same here. Bought Litspeed license for whm from cPanel. My server has pretty high specs. I have 256gb ram in my server. After installing litespeed and wp litspeed plugin my site speed dropped. I was hoping my site will perform better 🙁

Viewing 16 replies (of 16 total)
  • The topic ‘LiteSpeed underperforming’ is closed to new replies.