Support » Plugin: LiteSpeed Cache » Litespeed Crawler cache to slow

  • Resolved weboersma

    (@weboersma)


    Hello,
    I have installed LiteSpeed cache plugin.

    Page loading times (DomContentLoaded):
    – cache off: 2,0 seconds
    – cache on and cached via url previously loaded via browser: 300ms
    – cache on and Crawler active and Crawled: 1,5 seconds. (The header response says: “x-litespeed-cache: hit”, so there is some caching.)
    (Browser cache is always deleted)

    I assumed the Crawled pages would also result in 300 ms page load.
    Is my assumption right?
    If so: how can I speed up the Crawler cache?

    Kind regards Edzerd Boersma.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    – cache on and cached via url previously loaded via browser: 300ms
    – cache on and Crawler active and Crawled: 1,5 seconds. (The header

    not exactly , cache only cut/reduce the TTFB , but other parts like DNS lookup , SSL handshake …etc , are still out of cache scope

    please check the timing on all of them like DNS and SSL , I suspect these will affect result as well

    Best regards,

    Thread Starter weboersma

    (@weboersma)

    Hi,

    I understand, but DNS and SSL are not the problem.
    When I load a page on device A (laptop) with caching on, then it becomes also fast on the first load on another pc (device B), even on a smartphone with 4G (device C).
    When I turn caching off and select a new product, then for all devices it is slow.
    When I turn caching on and select a new page on device C, then that page is fast also on the first load on device A and B.

    Best regards,

    Thread Starter weboersma

    (@weboersma)

    supplemental information:
    When I use cache in an incognito-window then page loading is about 800ms (probably that’s a better test-case in this issue)

    Plugin Support qtwrk

    (@qtwrk)

    what’s timing you see on main request over these different tests/devices ?

    Thread Starter weboersma

    (@weboersma)

    All three devices give the same result, so which device makes no difference.
    Domcontentloaded with incognito window:
    – with cache made by getting page in browser: 0,8 seconds.
    – with cache made by Crawler 2,0 seconds:

    Plugin Support qtwrk

    (@qtwrk)

    please join our slack https://www.litespeedtech.com/slack

    I will check with you

    please let me know your username if you’d join in , or reach me by @qtwrk

    Thread Starter weboersma

    (@weboersma)

    Hello,
    I am joined, my user name is: ‘Wytze Boersma’.

    Plugin Support qtwrk

    (@qtwrk)

    thanks, I have messaged you .

    Thread Starter weboersma

    (@weboersma)

    After a lot of communication via Slack:
    It seems the Crawler does not work fully when ‘dynamic CSS’ is used.
    The first request are cached, but then the browser gets the content of the page, and via that content extra requests (subrequests) are done.
    The Crawler cannot cache that subrequests.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Litespeed Crawler cache to slow’ is closed to new replies.