• Resolved JJulien

    (@scabuster)


    Hello Litespeed cache developers,
    I have your cache plugin installed on more than one site. This issue I’m reporting is pervasive across all these sites. Specifically, when I test these sites using Lighthouse, the TTL for static assets is flagged because it is 604800000 seconds, which is over 19 years. Lighthouse would not flag it if it were set to one year, 31536000 seconds. Digging into the TTL settings tab of Litespeed cache, I see there some default values are 604800 seconds, which looks similar to the 604800000 that I am reporting, which leads me to think that the 604800000 is likely a mistake entry made by your team. I have changed setting in the TTL tab, and these do not affect these static assets TTL which I am reporting. I would like to ask you to kindly check with your developers to find out where the 604800000 is coming from, and to set it to 31536000 instead. My goal is for these static assets to have a TTL of 3156000 seconds.

    Link to site: https://lovebug.beauty/
    Report number: YIFWPQGL
    Link to Lighthouse test: https://www.webpagetest.org/result/230614_AiDcGF_95/
    Link to Screenshot from Lighthouse test: https://lbv1.domainactivation.com/mw459.jpg
    Instructions to reproduce the issue: Simply enter Lovebug.beauty into the Lighthouse entry box at https://www.webpagetest.org/lighthouse and press Start Test button.

    Thank you,
    Julien



    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support qtwrk

    (@qtwrk)

    I don’t see any TTL that is 604800000 from your report , and you did not even enable the browser cache from plugin

    have you fixed it already ? I am seeing these listed resources give max-age=604800

    Thread Starter JJulien

    (@scabuster)

    Hello,
    No, nothing has changed. The same results are still there. If you follow the example in the screenshot link, with heading ‘Serve static assets with an efficient cache policy’, you will see there under the TTL column 604800000. If you look in the Lighthouse report link for the same heading, you will see the same results.
    Where exactly are you seeing 604800?
    Thank you,
    Julien

    • This reply was modified 12 months ago by JJulien.
    Plugin Support qtwrk

    (@qtwrk)

    this is what I see in my browser

    and cache-control header is NOT controlled by plugin

    so whatever the issue is , it must be from server-level , instead of plugin-level

    Thread Starter JJulien

    (@scabuster)

    Hello,
    I saw that in the headers too, and it is not 604800000, so this Cache-Control must not be the origin. There are many different cache settings, within the server, within the plugin, and none that I could find matched 604800000 except for in the Lighthouse results. This is why I reported it to my host, and to Litespeed. My host responded similarly, that this is not a server side setting, this is LSCache’s default setting.

    I would like to ask you and other people here to test other sites which use LSCache, using Lighthouse, and check the same Performance heading ‘Serve static assets with an efficient cache policy’, TTL column to see if other servers are also reporting the same 604800000. This would help narrow down where the issue is coming from.
    Thank you,
    Julien

    • This reply was modified 12 months ago by JJulien.
    • This reply was modified 12 months ago by JJulien.
    • This reply was modified 12 months ago by JJulien.
    Plugin Support qtwrk

    (@qtwrk)

    I am pretty sure it is server-side issue , you can just simply disable the cache plugin and test again

    from what I know , there is no way the cache plugin will control the cache-control header

    the hosting provider can check the server log , it should have every detail for how or why that cache-control header is set to that high number.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Litespeed cache’s static asset cache TTL set to 19 years’ is closed to new replies.