WordPress.org

Support

Support » Themes and Templates » GamePress » [Resolved] Lists

[Resolved] Lists

  • Some elegant way to change default arrow list into cross or square ?
    Custom CSS ?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Theme Author alex27

    @alex27

    GamePress offers list schortcode (it has it’s own button in the HTML editor), where you can choose the image for the list.

    Yes but I need it on a global scale, default

      is arrow and it shows in every widget I use where I can’t just put some shortcode…

    Theme Author alex27

    @alex27

    Then your only option is to edit CSS. I highly recommend doing any changes via child theme.

    Yeah, I thought so…maybe good idea for next revision of theme ? ๐Ÿ™‚
    What about Appearance-Edit CSS ?
    There is option “Add my CSS to GamePress’s CSS stylesheet” .
    I tried but managed only not to see arrows at all…

    Theme Author alex27

    @alex27

    I can’t see the option you mention under Appereance->Editor. Are you using some plugin for that? To change arrows to something else you’d have to change the rule for .widget ul li {} and change the background image to something else than list-arrow.png

    Theme Author alex27

    @alex27

    You could also try out this plugin: http://wordpress.org/extend/plugins/my-custom-css/

    Probably JetPack plugin gives me ability to add custom css to theme…problem is it’s not working as it should, I must’ve added something wrong .Suppose it’s not enough just to add this :

    .widget ul li {
    padding-left: 18px;
    background: url(“images/list-cross.png”) no-repeat 0 6px;
    list-style:none;
    }

    I tried also to add everything and lose even arrow though I didn’t change it and this code should override default css :

    #sidebar {
    float: right;
    width: 300px;
    }

    /* Widgets */

    .widget{
    margin: 0 0 18px 0;
    clear: both;
    overflow: hidden;
    }
    .widget h3.widget-title {
    text-transform: uppercase;
    font-size: 18px;
    background: url(“images/border-solid.png”) repeat-x 0 100%;
    margin: 0 0 12px 0;
    padding: 0 0 6px 0;
    }
    .widget a{
    color: #FFFFFF !important;
    text-decoration: none;
    }
    .widget ul {padding: 0;}
    .widget ul li {
    padding-left: 18px;
    background: url(“images/list-arrow.png”) no-repeat 0 6px;
    list-style:none;
    }

    I have another option, to copy whole theme css and change it…then use “Don’t use GamePress’s CSS, and replace everything with my own CSS.” ?

    Thanks !

    Theme Author alex27

    @alex27

    This:

    .widget ul li {
    padding-left: 18px;
    background: url("images/list-cross.png") no-repeat 0 6px;
    list-style:none;
    }

    should be enough. At least if you changed it directly in style.css. As to why it dosn’t work via CSS editor I don’t know. Maybe try the plugin I suggested, see if it works better then Jetpack.

    I’ll try that plugin, thanks yet again !

    Hmmm, JetPack gave me ability to edit css…I deactivated it and install my-custom-css as sugessted . Nope, same here, lost arrows as usuall.
    Next step, installed ver. 0.9 GamePress Theme, no luck either…just spotted another problem . On AboutUs page I had [tabs] tag, worked fine, now I get [raw] tags all over the page…override it with <div class=”tabs-wrapper”><ul class=”tabs tabs-nav”> . Why is it hapenning ?

    About Us

    I just saw it’s a bug, though it’s fixed I can’t update to this fixed version :
    Destination folder already exists.
    Theme install failed.
    OK, I resolved it the other way as I said, but problem with lists remains…any thoughts ?

    Thanks, Miลกa

    Theme Author alex27

    @alex27

    I’m glad you figured out the bug. As for your original problem, I don’t have any new ideas. I’ll test My Custom CSS plugin and see if it works for me.

    OK, please let me know what happened !
    Waiting for ver. 1.0 ๐Ÿ™‚

    Theme Author alex27

    @alex27

    Ok, I tested My Custom CSS plugin and it works fine. The problem is with the path to image – you can’t use the same, relative path as I used in style.css. Instead you should provide full path to the image and all will be fine.
    So this:
    background: url("images/list-cross.png") no-repeat 0 6px;
    should be:
    background: url("http://www.magicbeans.rs/wp-content/themes/gamepress/images/list-cross.png")

    Hallelujah !
    It works now…thank a lot for your time !!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Lists’ is closed to new replies.
Skip to toolbar