Support » Plugins and Hacks » [Resolved] Listings not displaying

[Resolved] Listings not displaying

Viewing 10 replies - 1 through 10 (of 10 total)
  • PS – I’m using WordPress 3.5.

    Plugin Author businessdirectoryplugin


    Hi illusionrepository,

    So, did this recently change when you upgraded to WP 3.5? Have you recently added listings or is this a new install? Are the listings public and published?

    I don’t think it changed with the 3.5 update. I’ve been at 3.5 for a while, I believe. (Though i could be wrong…)

    It was working fine just a few days ago. The only thing I recall updating was the Jetpack plugin.

    The listings are all public and published

    Yep – it’s JetPack…

    I “disabled” it and the posts now show up. So something isn’t playing nice…

    Any chance to update the code to play nice? Or should I contact the JetPack people?

    Plugin Author businessdirectoryplugin


    We’re looking into it. It may be worth contacting them as well, since we haven’t found the source of the problem. Since it worked pre WP 3.5, it’s quite likely they did a recent update that caused this.

    It worked WITH wp 3.5 too. It was the Jetpack update to 2.0.4 that broke it. I’ll drop them a note.

    Plugin Author businessdirectoryplugin


    We’re seeing many reports of Jetpack 2.0.4 breaking other plugins. Not just BD or AWPCP, but these as well:


    That seems to point strongly in the court of Jetpack. I would suggest downgrading if you want that available for now.

    I just updated to the latest version of Business Directory 2.0.2 because my fields were not displaying after I moved my site to a new host. Only the pictures were displaying. As soon as I activated the upgraded plugin, the site crashed!

    Bluehost sent me this piece of code which may be the culprit but I do not know enough about php to debug it. Can anyone help?

    if (current_user_can(‘administrator’)) {
    $submenu[‘wpbdp_admin’][1][2] = admin_url(sprintf(‘post-new.php?post_type=%s’, wpbdp_post_type()));
    $submenu[‘wpbdp_admin’][0][0] = _x(‘Main Menu’, ‘admin menu’, ‘WPBDM’);
    $submenu[‘wpbdp_admin’][5][2] = admin_url(sprintf(‘edit.php?post_type=%s&wpbdmfilter=%s’, wpbdp()->get_post_type(), ‘pendingupgrade’));
    $submenu[‘wpbdp_admin’][6][2] = admin_url(sprintf(‘edit.php?post_type=%s&wpbdmfilter=%s’,

    Plugin Author businessdirectoryplugin


    Business Directory’s latest version is 2.2, not 2.0.2. Which version are you using?

    The code above isn’t necessarily the cause of the crash here–there’s nothing that would indicate that it’s bringing a site down (using something like a query or a bad reference). The same code is running on hundreds of other sites, so let’s get a bigger picture here:

    – What version of WP are you running?
    – Are you on shared or dedicated hosting?
    – Windows or Linux hosting?
    – Explain how this move to a new host was done–in as much detail as possible, please.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Listings not displaying’ is closed to new replies.