Support » Plugin: amr users » list is not saved

  • Resolved phacx

    (@phacx)


    I have configured a list in the Configure a user list: form, I update, I view the list – no issues. Then every time I switch in the menu to Overview&Tools, do nothing but return to the Configure a user list: page, the user list is empty. I select the list again and it is still empty, looks like the previous update doesn’t save the data in de DB

    I like this plugin but without saving the list configuration it is useless.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author anmari

    (@anmari)

    That sounds very odd. It sounds like you mean that the list configuration is saved, the list runs correctly but then after that the cached data is not available, so the list shows empty the next time it is run.

    This could be a few things, from database errors to performance, to cache being constantly rebuilt due to updates.
    Is this a live site? How many users and usermeta?
    What recache settings are you using ? Just to see what is going on, try setting it to cache on manual request only, or hourly/daily. See https://wpusersplugin.com/3458/cacheing-amr-users/

    Please also check

    1. the cache log – that may shed some light on what is happening
    2. the system logs – are there any database errors

    and advise your stats from …wp-admin/admin.php?page=amr-users&tab=userdb

    Thread Starter phacx

    (@phacx)

    It’s a live site but in development with only 22 users. To verify no interaction from theme or other plugins I have also tested with all plugins deactivated apart from amr en with the Twenty-One theme. Results are the same.

    Caching amr-users is:
    – Do NOT re-cache on user update
    – No scheduled auto cacheing

    cache log today, last lines, as a result of manual ‘rebuild cache now’:
    2021-02-15 09:24:47 – Completed user-01 in 0.04 microseconds
    2021-02-15 09:24:47 – Cached next batch of 22 from 0
    2021-02-15 09:24:47 – Cache record, but no transient yet? user-01
    2021-02-15 09:24:44 – Completed user-01 in 0.03 microseconds
    2021-02-15 09:24:44 – Cached next batch of 22 from 0
    2021-02-15 09:24:44 – Cache record, but no transient yet? user-01

    debug log today, I have switched on WP DEBUG:

    [15-Feb-2021 09:23:31 UTC] PHP Notice: Undefined index: hook_suffix in /home/valkenburg/domains/ac-valkenburg.nl/public_html/wordpress/acv-develop/wp-admin/includes/class-wp-screen.php on line 223
    [15-Feb-2021 09:24:27 UTC] PHP Notice: Undefined index: in /home/valkenburg/domains/ac-valkenburg.nl/public_html/wordpress/acv-develop/wp-content/plugins/amr-users/includes/ameta-admin-configure.php on line 792
    [15-Feb-2021 09:24:27 UTC] PHP Notice: Undefined index: in /home/valkenburg/domains/ac-valkenburg.nl/public_html/wordpress/acv-develop/wp-content/plugins/amr-users/includes/ameta-admin.php on line 342
    [15-Feb-2021 09:24:27 UTC] PHP Notice: Undefined index: in /home/valkenburg/domains/ac-valkenburg.nl/public_html/wordpress/acv-develop/wp-content/plugins/amr-users/includes/ameta-admin.php on line 343

    Stats:

    This website with blog_id=1 and prefix=wp_d_ has:
    Plugin version: 4.46
    Php version: 5.6.33
    Wp version: 5.6.1
    Php maximum execution time is: 45
    Wordpress Memory limit: 256M
    Wordpress Max Memory limit: 256M
    Php Memory Limit: 256M
    Charset: UTF-8

    At debug only: At 0.000 seconds, peak mem= 20.25 mb real_mem=20.25 mb – Before count users:
    There are 22 total users: 1 administrator, 1 editor, 1 author, 1 contributor, 16 subscriber, 1 um_voorzitter, 1 instrukteur, 2 css_js_designer, 3 webmaster, 5 belangstellend_lid, 1 partner, 2 technicus, 1 lid_van_verdienste, 1 penningmeester, 2 bestuurs_lid_acv, 2 bestuurs_lid_betav, 1 operations, 0 none,

    At debug only: At 0.003 seconds, peak mem= 20.25 mb real_mem=20.25 mb – After count users:

    No system messages logged related to wordpress or amr

    Plugin Author anmari

    (@anmari)

    Well you certainly shouldn’t be having performance issues. Your php version could use an upgrade. WordPress requirement is 7.4 or greater https://en-au.wordpress.org/about/requirements/.

    I’m not getting the errors you are getting, although I haven’t tried to recreate on a totally clean install.

    The hook_suffix is an odd one – googling that doesn’t shed much light. I found this https://wordpress.org/support/topic/php-notice-undefined-index-hook_suffix/ which ended up calling it a core bug, but I’d hesitate to say that – those usually get picked up. maybe upgrade the php version and see if that one goes away?

    Re the other 3 seem to be either a parameter that is empty when it should not be or a global option that doesn’t have the expected data. Happening in admin screens and to do with the main list of userlists where names of the list are stored. SAVE the settings in the overview screen and see if that makes a difference.

    I suggest upgrade the php. If error still occurs after upgrade, then reset the stored amr-user options. There is a button in settings to do that. Or you can just delete all amr% in the wp_options table and let it reset to defaults. The see if it happens with just the basic default list. save the settings in the overview screen again.

    Let me know how you go please.

    Thread Starter phacx

    (@phacx)

    Problem is solved after upgrade to PHP 7.4.

    But I’m still a bit puzzled why this is happening with PHP 5.6 and no error loggings are shown. Anyhow, it is solved thnx for your support.

    Plugin Author anmari

    (@anmari)

    good to hear it’s fixed – it is way better to be up to date. Sometimes there are backwardly incompatible changes (ie the way PHP handles things changes completely and code that works on 7 will give different result on lower versions). It is usually not worth it (or vey expensive) to maintain compatibility with old versions which is why wordpress doesn’t do 5.x anymore.

    It is therefore imperative that one stays reasonably up to date. Your wordpress setup should have been warning you somewhere that you are on old PHP and nudging you to update

    See https://www.php.net/manual/en/migration70.php and
    https://www.php.net/manual/en/migration70.incompatible.php
    and
    https://www.securityweek.com/wordpress-warn-outdated-php-versions#:~:text=In%20an%20effort%20to%20improve,using%20PHP%205.6%20or%20above.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘list is not saved’ is closed to new replies.