• Resolved Ian Scott

    (@ianhughscott)


    I have Linode Object storage and am trying to configure UpdraftPlus on a site to use it.

    The instructions that UpdraftPlus seem to be in need of an update. First, there are no “API Keys” in my Linode profile – there are API Tokens and I do not get a generated “secret token” – just one token.

    I did also try generating a public and secret key for the bucket itself, but Updraft Plus still gives an error – it was able to connect to the bucket (sorry, can’t recall the exact wording) but could not write a file, even though the key has read/write access.

    What could I be doing wrong, or are the instructions on the UpdraftPlus Linode guide incorrect?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Thread Starter Ian Scott

    (@ianhughscott)

    Here is the error message when I use the access keys created and provided read/write access to the bucket, and then click on the “Test S3 Compatible Generic Settings:

    S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [SignatureDoesNotMatch] )

    Just in case I miscopied the keys, I revoked and then created new access keys and downloaded them – so I am very sure I have copy and pasted exactly.

    • This reply was modified 1 year ago by Ian Scott.
    Thread Starter Ian Scott

    (@ianhughscott)

    More information: I downloaded a trial copy of ExpanDrive to test things (I use Linux desktop).

    So, when entering only the servername and then optionally, the bucket name, and entering the access and secret keys, I had no problem viewing and transferring a file into the bucket.

    I have tried with UpdraftPlus:

    S3 Location: us-east-1.linodeobjects.com
    Endpoint: MyBucketName

    And other combinations.

    I have double and triple (and even more) checked the Access and Secret keys, several times copy and pasting and making sure there are no spaces at the beginning or end.

    UpdraftPlus simply generates the error when clicking the test settings.

    Am providing this information in case it is helpful to troubleshoot and with the fact I WAS able to connect and put a file, using ExpanDrive.

    • This reply was modified 1 year ago by Ian Scott.
    Plugin Support vupdraft

    (@vupdraft)

    Hi Ian ,

    Apologies for this, I will add a note internally to get the instructions updated.

    Thread Starter Ian Scott

    (@ianhughscott)

    Thanks, but can you help me to get this to work now? What do I need to do? As mentioned, entering the public and secret key for the bucket and testing, fails.

    I realize your instructions are mostly likely incorrect, but assuming I have figured out the issue, I still get a failure to connect with a public and private key for the bucket.

    But I can connect with another app, with the same credentials.

    It is not just the instructions that are at issue here.

    Thread Starter Ian Scott

    (@ianhughscott)

    Hello @vupdraft – perhaps I should open a new thread here?

    While my support request is entitled “Linode Instructions,” if you read through my followups, it is more than the instructions.

    I am fairly certain that I know what is supposed to be done – creating a key pair that gives read/write permissions to a bucket, entering those in your plugin, and setting the region and then the bucket name.

    This is not working for me with your plugin although I am able to configure another app with the same credentials, and successfully write to the bucket.

    Can you help with this issue?

    • This reply was modified 1 year ago by Ian Scott.
    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies for the delay in replying.

    Please could you check that your server’s clock is configured to the correct time? UpdraftPlus will show this time on the dashboard.

    The UTC time shown needs to be accurate. If the clock is off, you will need to ask your webserver admin to adjust the server clock.

    Thread Starter Ian Scott

    (@ianhughscott)

    In local time, the clock is dead on.
    A minute ago:
    Wed, April 5, 2023 15:20

    I also manage the server the site is on. The clock is regularly synced to a time server.

    Plugin Support vupdraft

    (@vupdraft)

    Hi Ian,

    Apologies for the delay, I have asked our developer to follow up on this.

    Thread Starter Ian Scott

    (@ianhughscott)

    Thanks. If we can get this working, I’ll definitely be considering upgrading – but Linode storage is something I already have, and so is important for me.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies, could I check if you hav tested both the ‘path’ and ‘virtual host’ bucket access styles?

    Thread Starter Ian Scott

    (@ianhughscott)

    I did try both, yes. When I try ‘virtual host’ style, I get the error message:

    “S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [51] Unable to communicate securely with peer: requested domain name does not match the server’s certificate.)”

    Note, this is a slightly different error with the added error about server certificate.

    Thread Starter Ian Scott

    (@ianhughscott)

    Playing around a bit more:

    If I type in the s3location s3generic//: us-east-1.linodeobjects.com

    Then in s-3 endpoint: mybucketname

    Then try to Test, error message is:

    S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [6] Could not resolve host: mybucketname; Unknown error)

    This seems weird to me because the “mybucketname” is the end point.

    So, I try with the same us-east-1.linodeobjects.com

    and in end point, I type in:

    mybucketname.us-east-1.linodeobjects.com

    the error message is:

    “S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [SignatureDoesNotMatch] )”

    If I type in mybucketname.us-east-1.linodeobjects.com in both fields, I get:

    “S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [SignatureDoesNotMatch] )”

    PLEASE NOTE: mybucketname is not the actual name – for security, I have substituted that here, for the actual bucket name.

    I have double and tripled checked the credentials and am absolutely positive they are correct.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    I am going to consult with our lead developer and update you when I hear back.

    Plugin Author David Anderson

    (@davidanderson)

    “This seems weird to me because the “mybucketname” is the end point.”

    In the S3 protocol, the “end-point” is the DNS hostname to contact, i.e. the server to contact. Hence in the instructions, “The end-point is (region).linodeobjects.com – e.g. us-east-1.linodeobjects.com” (see the screenshot below).”

    S3 Location: us-east-1.linodeobjects.com

    In the “location” field, you enter a bucket name, only, as per the tooltip that appears if you hover over it: https://snipboard.io/x8KcPy.jpg. So in your example, you should be entering mybucketname

    Apologies that my colleagues missed this in the description of your problem; you’re just entering those two parameters the wrong way round.

    Thread Starter Ian Scott

    (@ianhughscott)

    As I have pointed out, I have already tried that – but this absolutely does not work. I can confirm that the S3 Location is us-east-1.linodeobjects.com

    and S3 endpoint is “mybucketname”

    In this case, as mentioned above, I get a host not found error:

    S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [6] Could not resolve host: mybucketname; Unknown error)

    The above is the error with Path Style.

    With virtual host style, the error becomes:

    “S3-Compatible (Generic) settings test result: Failure: We successfully accessed the bucket, but the attempt to create a file in it failed. Please check your access credentials. (UpdraftPlus_S3::putObject(): [6] Could not resolve host: us-east-1.linodeobjects.com.mybucketname; Unknown error)


    This is actually what I tried initially as I understand that the endpoint is the bucket name, and the location is the address of where the bucket is located. I got the strange (to me) host resolution errors, so began to experiment.

    At least with putting in the full url in the S3 endpoint, ie mybucketname.us-east-1.linodeobjects.com, there is no host resolution error – instead, errors about being able to access the bucket but not able to write a file – please check credentials.

    As mentioned, I have double checked the credentials many times, even creating new keys with read/write access to the bucket just in case I did something wrong, and they all fail.

    But I can access the bucket using a different app (ExpanDrive) with the same credentials.

    Did you ever have your developer look into this and try themselves with the S3 Compatible settings and Linode Objects storage, and your free version of this plugin?

    Would you like me to provide you with admin access so you can try for yourself and see what I am viewing with the various settings? I will even create a new bucket, provide you with the credentials, for testing purposes, but I can assure you it’s not working correctly.

    Even the fact that I enter the information that should be the correct way (ie, endpoint is ONLY the bucket name and S3 location is only the linode address – us-east-1.linodeobjects.com) but that generates a host resolution error indicates there is something else going on that is not correct.



Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Linode Instructions’ is closed to new replies.