Support » Plugin: Ultimate TinyMCE » link/unlink permanently disabled

Viewing 15 replies - 31 through 45 (of 57 total)
  • Plugin Author Josh

    (@josh401)

    Make sure your current WP version is up to date.. and yes, also update your theme.

    The “Customizations will be Lost” message applies to any customizations you have made to core WP files, such as the style.css, functions.php, or any of the template files.

    It will NOT lose your theme settings, sidebars, widgets, etc.

    ok. i did that. now should I still switch to the default WP theme? And if I do, will all my sidebars and widgets and stuff still be there when i switch back to Twenty Ten? And am I doing this just to see if this brings back the “add link” button?

    Plugin Author Josh

    (@josh401)

    Yes; I hope so; and yes.

    I have seen some themes have trouble with widgets when switching… but I’m almost positive the WP themes will have no trouble.

    The worst it might to.. is move your widgets to the “inactive widgets” section.. and you may need to “place” them again.

    okay. tried that. it did not make the link buttons live.

    News Flash: We just learned that this problem only occurs when using Firefox, not safari or Chrome…..

    Josh, you may wish to look at the code for the Firefox browser.

    I use Chrome and had the issue with the link/unlink buttons.

    Plugin Author Josh

    (@josh401)

    Okay, I just tried all of the following browsers without any problem whatsoever:

    1. Firefox 23.0
    2. Chrome 28.0.1500.95 m
    3. Opera 12.16 Build 1860
    4. IE 10.0.9200

    Here are the assumptions:

    1. I tested using BOTH the normal WP link and unlink buttons; as well as the “Advanced link/unlink” button added by Ultimate Tinymce.

    2. This is with no other plugins activated, and using the default WP theme (although it also works in my production sites just fine).

    This is very boggling. I am unable to replicate the issue at all.

    I have the OP’s site login info. Per his permission, I’d like to go in there and deactivate ALL plugins, switch to the default theme… and test this myself on a site which is experiencing the issue.

    I need solution to this issue too.. I am seeing on some new sites and have not been able to find a solution.

    I have deactivated everything,returned to default templates etc.. and the problem of ‘inactive’ link buttons has continued.

    I too use CF7 and NextGen

    G

    Plugin Author Josh

    (@josh401)

    Okay, I’ve got it.

    It’s NextGen guys.

    I had to install and activate both Contact Form 7 (Which worked fine), and also the NextGen Gallery plugin.

    As soon as I activated NextGen… I went to create a page.. and the link/unlink button was not working properly.

    Deactivating NextGen restored the button functionality.

    I am going to have to dig through his plugin, and see if I can find what’s going on.

    Hey Josh,

    I had all my plugins deactivated as per where we finished off last night, and I went back in just now and re-activated some of them…but NOT NextGEN, and the link buttons still weren’t functioning.

    I’ve also disabled the contact form included in Jetpack…I found an article about how that conflicts with Contact Form.

    Plugin Author Josh

    (@josh401)

    I went back in just now and re-activated some of them…but NOT NextGEN, and the link buttons still weren’t functioning.

    Did you manually empty and clear your browser cache afterwards?

    Guys, this is NextGen. For sure. I have been reading their support forum… and they are having a significant number of issues.

    I’m working through the code now.. but it’s really difficult trying to read someone else’s code. I was going to submit a ticket to them… but, as we see, that might be a long shot.

    I will definitely post back if I find a solution. I am able to replicate the problem… but ONLY with NextGen activated. If I deactivate NextGen, the problem disappears.

    I’ll keep pounding through it…

    NOTE: There is also something weird going on with the NextGen button that is placed in the editor toolbar. If you click that button.. and then exit out of the window… you will notice BOTH the link AND the unlink button are activated.

    Also, when you close the NextGen window (without inserting anything), you will notice the cursor inside the editor drops down two lines.

    I think we are dealing with some “buggy” javascript here. I’m looking through all the NextGen editor files now…

    Plugin Author Josh

    (@josh401)

    Okay… Here is the fix.

    In NextGen gallery files.. navigate to the following file:

    nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/static/ngg_attach_to_post_tinymce_plugin

    Sheesh.

    Okay, now open that javascript file in your favorite code editor.

    What we are going to do is take the code on line # 78, which is currently this:

    return false;

    And we are going to change it to this:

    //return false;

    Basically, we are commenting out, or preventing that line of code from executing.

    Now, I have NO idea what affect this will have on the functionality of the NextGen plugin; but this is definitely the issue.

    Commenting out that line, restores the link/unlink buttons of the visual editor, and allows them to function properly.

    Can someone please confirm?

    Tested it quickly on one site… The change DID return the functionality of the link buttons. No problems with NexTGen discovered yet.

    Thanks Josh ✔

    Josh thanks for this, I have same issue, & just thought I’d point out that your fix didn’t seem to work for me. I did exactly what you directed (commenting out line 78 in that /ngg_attach_to_post_tinymce_plugin.js file).

    I also have Contact form 7, if that’s a factor, noticed others mention that. Also when I deactivate Nextgen it makes no difference.

    Hope someone can crack it, it’s a small annoyance 🙂

    update: also (doh) I just noticed this is a ultimate TinyMC plug in thread which I did not have installed. Out of curiosity I installed it to see if this fixed the issue (in combination with above fix) but it did not. Same issue, with or without the (obviously fine) plug-in.

Viewing 15 replies - 31 through 45 (of 57 total)
  • The topic ‘link/unlink permanently disabled’ is closed to new replies.