WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Link/Unlink buttons not working

[Resolved] Link/Unlink buttons not working

  • I moved my site up to WordPress 3.9 today and moved TinyMCE Advanced up to Version 4.0. The Link and Unlink buttons in the editor do absolutely nothing at all; this is true even when I deactivate TinyMCE Advanced. I can work around this, since I can add links in the text editor, but it’s going to be a much larger issue for some of the other site authors. Any suggestions?

    https://wordpress.org/plugins/tinymce-advanced/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    Sounds like cache problem (the internal linking modal fails to load?). Are there any errors in the browser console?

    Yes–“wpLinkL10n is not defined

    Line 1″

    Thanks. I do use W3 Total Cache for the site but I cleared its caches as well as my browser cache and tried logging into WordPress with a browser other than the one I normally use–no joy anywhere.

    Same problem here. Any ideas anyone? Driving me nuts.

    After some troubleshooting, in my case I determined that there was a plugin conflict causing this issue. My site was using a plugin that added a checkbox to the dialog for links, so that it was easy to set the links to include the rel=”nofollow” attribute. Once that plugin was deactivated, the links tools work correctly.

    Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    I’m glad you found the problem. Perhaps post on the main support forum too so other people would know how to fix/which plugin was causing it.

    The conflict was with the Rel Nofollow Checkbox plugin; once it was deactivated, the link/unlink tools worked correctly.

    I recently updated to 3.9 and my links buttons and Squirrly SEO plug in isn’t working. I tried disabling all plugins to see if that affected the links buttons issue but no change and I updated Squirrly but it still doesn’t load.

    esmi

    @esmi

    Forum Moderator

    @djfwobbly: If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else’s topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Link/Unlink buttons not working’ is closed to new replies.