Support » Plugin: Social Sharing Toolkit » Linksalpha button…really?

  • Really loved this plugin, saw update, updated and now I have a linkalpha button that can’t be removed..

    Quite annoying, disabled plugin.

    I mean I am all for supporting a developer but for it to just be added without me knowing and not able to modify or disable it… not cool.

Viewing 15 replies - 16 through 30 (of 63 total)
  • My problem is different…
    I have on sidebar the links to another page wiht different url

    before this problem i have the widget of Social Sharing toolkit with url
    and this
    For share on social site.

    Now i want other plugin for this…

    You can help me please?

    Running a previous version due to the Linksalpha button. Shareholic seems nice @newyears1978. I might give that one a try.

    This seems to be devious tactic by the plugin developers – I mean, the untick option is even there but greyed out ! :-O

    The default option completely messed up my layout, so without removing one of the share icons that I actually want, there’s no way for this widget to fit in the required space.

    PLEASE make this optional !

    I too was forced to disable. The self-promotion button that I can’t uncheck destroyed the alignment with other items below my post, so the plugin had to go.

    Self-promotion on a free plugin? Totally fine. Forcing the change with no explanation, no warning, and no way to throw you some cash to opt out? Totally not.

    Yes – and a real shame cos I did like the great functionality yet simple design of this. What’s everyone else using instead – is there another all-in-one share/like/follow as good as this one ?

    Currently I’m looking at these 3 separate plugins to replace the functionality of this one –

    Simple Social Icons –
    Facebook Like Button Plugin –
    Simple Share Buttons Adder –



    Totally messed up my site. It’s a pretty custom sote so the button not only threw off the entire layout, but my homepage also loads WAY slower now. I reverted back to the previous version and all is well. Hopefully the developer decides to make this button optional, otherwise I have to look for another option.

    Hi there Guys,

    I had the same problem as you with this button being added, so I just added a little CSS to the theme stylesheet and Gone! It is always better to keep plugins up to date due to a vulnerabilities that may be found between the plugin you are using and WordPress.

    Add the following into your themes CSS File
    .linksalpha_image {
    display: none !important;
    Hope this helps.
    Kind regards

    Hello Guys,

    there is also an additional fix.

    You have to go to your directory on your server, where you installed wordpress.
    Then go to /wp-content/plugins/social-sharing-toolkit/includes/buttons and delete the file button.linkalpha.php ….
    Then the plugin can’t include the picture or button of linksalpha and your social button are free of the advertise…

    Kind regards


    hi there Norman,

    That is an excellent fix but when the updates are done to the plugin, surely to image will be re-added to the folder? Then you will need to go in and remove it again.

    Your thoughts.

    Kind regards

    add to style.css

    .mr_social_sharing_wrapper .linksalpha_image {
    display: none !important;
    display: none;

    Hey guys. The thing is after next update the whole file structure will be updated and the files you have deleted will be there again. I’ve found easier way to fix it.
    First of all, insted of changing a style.css, you can put some styles in the Custom Css section within the plugin admin menu. But you need to get rid of the link not just an image of button!!! So, take a look at the source code of the page and find out under what class or section it’s located and what styles you have to apply. Notice, depending on your settings of the plugin my solution may not be the best for your site, as it can make other buttons desapear too (I supose:), but you as ease can delete this style and make everything look as before. Ok, this is what I used:

    span.mr_social_sharing a {
    display: none !important;

    Inset this into your theme css file, nothing to do with the plugin files 🙂

    .mr_social_sharing_wrapper .linksalpha_image {
    display: none !important;
    display: none;

    I have to admit, after disabling this plugin I Gained back about half of my box memory. The little happy linksalpha addon has z-index issues. I suppose it sets ontop of everything else 🙂


    Hi there sirrieh70

    I was very interested to read that this plugin is eating up your memory. Have you found a better plugin and if so, which one?

    Thanks in advance for your advice.



    The button is one thing but as sirrieh70 said, there is also a memory issue. It affects my load time considerably. My homepage has many, many sharing links so I’m the perfect test subject. I can tell you that the load time between the last version and this version is drastic. The point is CSS tweaks can’t help this. The button has to have the option of being completely disabled.

    In the file /includes/buttons/button.linksalpha.php fomment out the linksalphe code. And the button is gone!!!

    #$retval =  '<a href="//">
    		#			<img src="//'.$image.'" alt="Share" class="linksalpha_image" />
    		#			</a><script type="text/javascript" src="//'.urlencode($url).'&id='.rand().'"></script>';
    		#return $retval;
    		return '';

    I hate it when i am forced to show something i dont like to show!!!

Viewing 15 replies - 16 through 30 (of 63 total)
  • The topic ‘Linksalpha button…really?’ is closed to new replies.