Links won't open with left-click (7 posts)

  1. PatJenningsBigGloves
    Posted 3 years ago #

    Hi. Just installed the Blaskan theme and for some reason none of the menu items or other links on my pages will open when I left-click, I have to right click to open in new tab/page. I can't find this in any 'known bugs' list, so assume it's something in my theme settings? Anyone else come had this problem? Site is http://www.buffdaddio.com

    Thanks for any help,


  2. Davide Laganà
    Posted 3 years ago #

    Just upgraded to Blaskan 2.6.4 and WP 3.5.1 (coming from perfectly-working Blaskan 2.5 and WP 3.4.1). Same behaviour as OP, but only on certain conditions:

    Machine 1 (Win8 x64, Wacom Bamboo Pen & Touch):

    Chrome (latest beta) 26.0.1410.28 beta-m / Chrome Canary / Firefox 19.0.2
    left click doesn't work

    Internet Explorer 10.0.9200.16484
    left click works


    Machine 2 (Win8 x64, mouse):

    Chrome (latest stable)
    left click works


    iPad / Android phone:
    tapping works

    All browsers tried with no extensions / anonymous session. This bug happens also on http://demo.blaskan.net/

    EDIT: seems that issue is related to "touch events" support. If I disable them on both Chrome (from chrome://flags) and Firefox (from about:config > dom.w3c_touch_events.enabled = 0), left click works just as it should.

    Blaskan 2.5 worked flawlessly with these options set on "Auto" (default for both Chrome Beta and Firefox)!

    Dunno if could be related my Wacom Bamboo tablet, left click = pen click = one finger tapping either do not work.

  3. PatJenningsBigGloves
    Posted 3 years ago #

    Thanks for the feedback. I have same browser and Windows setup (Chrome, Win8) and using laptop touchpad and still no left-click possible. Works fine on Blackberry. I've switched themes now, was trialing Blaskan as I liked theme and responsiveness to devices.

  4. Anna1923
    Posted 3 years ago #

    I had same issue after installing Blaskan 2.6.4 -links are not working when using laptop touchpad on Win8 (either on Chrome or Firefox. It works only by disabling "touch events" but that's not the solution. I can't ask the visitors who use touchpad to disable that function each time they are on my website. Therefore, unfortunately, I had to uninstall that theme and install another, the one I used previously. I hope that this will be fixed soon cause I really like that theme and would love to use it.

  5. TraciBunkers
    Posted 3 years ago #

    I am having the same trouble, but only on an iPhone--they are okay on my ipad.

    EDIT: I wanted to clarify, for me, it's just the child menu links that don't work, as in noting happens when you click on the child. The browser doesn't seem to make a difference.

  6. TraciBunkers
    Posted 3 years ago #

    I found a fix for this--the Jquery Accordion Menu Widget plugin.

    I was hesitant to try it because it hasn't been updated in awhile. But I installed it, then in the widget, I selected my menu, clicked on "hover", "auto close open menus" and "Close Menu (hover only)". Saved it, and that was it! I tested it on my ipad & iphone, and those menus work now! None of my custom css styling needed to be changed.

  7. ShaunG
    Posted 2 years ago #

    Possible solution for people using Google Chrome from a touch enabled laptop: http://wordpress.org/support/topic/blaskan-theme-and-chrome-unable-to-click-any-links?replies=9#post-5276248

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic