Support » Plugin: Translate Multilingual sites - TranslatePress » Links to mediafile broken

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Dragos

    (@dragosvrejiu)

    Hello,

    You can exclude the link from being translated by adding the data-no-translation attribute.
    Please check our documentation for further information:https://translatepress.com/docs/developers/exclude-certain-text-or-element-from-being-translated/

    Let me know how this goes.

    Best regards,

    Thread Starter kaytellehoel

    (@kaytellehoelgmailcom)

    I’m using Elementor page-builder. When adding “data-no-translation” to the button attributes, the text on the button is not translated, but the link is still messed up. I tried adding an image with the link and using the “data-no-translation” to the attributes, didn’t work. Added a text link with “data-no-translation” inside the a href tag, doesn’t work.

    Adding the language extension “en” to media library links by default doesn’t seem like an optimal solution. But I understand it can be challenging to detect this automatically.

    • This reply was modified 1 year, 11 months ago by kaytellehoel.
    • This reply was modified 1 year, 11 months ago by kaytellehoel.
    Plugin Support Dragos

    (@dragosvrejiu)

    Hi,

    Can you please visit TranslatePress -> Settings -> Advanced

    Then, enable these features 1 by 1 in this order and try to see if it makes a difference. Also please disable or clear the cache if you have any.

    1. Fix missing dynamic content
    2. Disable dynamic translation
    3. Fix spaces between HTML attributes
    4. Fix broken HTML

    Let me know how this goes.

    Best regards,

    Thread Starter kaytellehoel

    (@kaytellehoelgmailcom)

    Thanks @dragosvrejiu

    This actually appears to have been a cache issue. After I pushed the staging site to live and tried the links again to day, it worked fine.

    Thanks for your support.

    Plugin Support Dragos

    (@dragosvrejiu)

    Hi,

    I’m glad that you have solved the issue.

    Also, I was wondering, once you will have started using TranslatePress for a while, will it be too much to ask for you to leave a review on https://wordpress.org/support/plugin/translatepress-multilingual/reviews/ ?

    One or two sentences will do it and it may help us to reach more people as well as get feedback from existing users.

    Kind regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Links to mediafile broken’ is closed to new replies.