Support » Localhost Installs » LInks to localhost url but not IP#

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you have access to your site’s dashboard, you can change the site address at SETTINGS => GENERAL. In most cases, you want to change both the “WordPress Address” and “Site Address” and have them be the same.

    But if you manually created this link somewhere on your site, then you may have to drill down to where you made this link and change the URL. Alternatively, you may use a plugin like “Better Search and Replace” to replace all occurrences of the IP with “localhost” (Backup, backup, backup!!!)

    Good luck!

    Thread Starter ozstar

    (@ozstar)

    Thank you.

    I checked the urls in Settings and they are both localhost/mysite but greyed out so looks lie I could not have changed them if I wanted to, not from there anyway.

    I did get that ‘Plug in’ you mentioned and tried it on the links setting only and it came back nothing to change.

    Backed up to Dropbox before too 🙂

    It is really weird because they are all pages I have created in the same admin and I don’t know why they would have the ‘IP#’ as url and not ‘localhost’ as others do. It’s not as if they are links I have inserted in a page, these are the links to the page.

    If I could only get to see a list of every page link, then I would know better of where to change them.

    It’s got me beat as I have looked everywhere.

    Thanks for the ‘Good luck’ too, looks like I might need it.

    I checked the urls in Settings and they are both localhost/mysite but greyed out so looks lie I could not have changed them if I wanted to, not from there anyway.

    The field being greyed out means the URLs have been hard-coded or defined in the site’s wp-config.php file.

    But since you have the correct WordPress/Site URLs already, nothing to do here.

    Where are you seeing the URL with the IP address anyway? Can you provide a full-page screenshot showing the link with the URL that uses the IP address?

    Also, did you originally set up the site with the IP address before you changed it to the localhost address (perhaps by defining the localhost URLs in the wp-config.php file — which would explain why they’re greyed out in the dashboard)?

    What is not clear to me — which I’m trying to understand with the two questions above — is if this is a PERMALINK (URL) generated by WordPress itself that has the IP address, or if it is simply a LINK you (or your theme a plugin) inserted somewhere on the site that used the “wrong” URL.

    Thread Starter ozstar

    (@ozstar)

    Thank you again.

    Yes that is the $64,000 dollar question for me too !

    I have to leave here now but will investigate it all and post some screen shots tomorrow.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.