WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Links stopped working after site migration (2 posts)

  1. slash84
    Member
    Posted 4 years ago #

    Hi all,
    I recently moved from a smaller hosting company to GoDaddy. Little did i know that GoDaddy has one of the worst UI's that i had ever come across. However after a day of failing, i finally managed to restore the databases sucessfully and install a new copy of the wordpress blog.

    I have a problem with all the links in my blog (www.atechiesthoughts.com). I made sure that the wp-config file has the right database and other details. I triple checked the databases manually to make sure the database has been restored in the right manner. But still, the links havent worked. Anyone has an idea about this problem, and how this can be fixed?

    EDIT: i might have stumbled on something here. I went to the "permalinks" option and changed the setting to default, and all the links are working fine. However when i change it to anything other than the default option, it stops working. Can anyone help me figure this out?

  2. slash84
    Member
    Posted 4 years ago #

    This is how i fixed my problem.
    I used the file manager to delete the .htaccess file(You can rename it to be on the safer side). Then i went to the WordPress admin settings page and clicked on "permalinks". There i changed the setting to default and applied the new setting. Then i changed it to the setting i wanted and applied the new setting again. It worked! What happens here is, a new .htaccess file is written and the links will start working again.

Topic Closed

This topic has been closed to new replies.

About this Topic