Support » Plugin: WP Staging - DB & File Duplicator & Migration » Links Redirecting To Old Site

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Rene Hermenau

    (@renehermi)

    Hi @lab41

    please activate the permalinks on the staging site from settings > permalinks

    Is this resolving the issue?

    I’ve tried that 3 times. It didn’t work. The only one that works is the native ?p=id type but I want to use the slug ones.

    Plugin Author Rene Hermenau

    (@renehermi)

    What is your webserver, nginx?

    In that case please read that link, it will explain how to activate permalinks on nginx:

    https://wp-staging.com/docs/activate-permalinks-staging-site/

    Hi

    It’s a client site. I have no idea if they’re running nginx. I’m pretty sure it’s Apache though.

    Plugin Author Rene Hermenau

    (@renehermi)

    You can see that on wp-staging > tools > system info

    It might be easier if you get in contact with me directly at support [at] wp-staging.com

    I find a solution for you.

    Hello,

    unfortunately I’ve got the same problem, so it would be nice if you could make the solution public here in the support forum.

    btw: my site is on a 1&1 shared server (package: unlimited plus)

    Thank you

    Plugin Author Rene Hermenau

    (@renehermi)

    @mrlovebucket In that particular case it was an issue with the user’s theme which did not allow to enable permalinks on the staging site. The solution was to deactivate permalinks and then to activate them again.

    if you contact me to my mail and send me the system info log from wp staging > tools I will likely find a solution to your issue as well.

    Cheers
    René

    @renehermi The solution worked for me as well. Now I have several staging sites and all are working like a charm.

    Thank you very much
    and have a nice day
    Mark

    Plugin Author Rene Hermenau

    (@renehermi)

    @mrlovebucket This is great. Thanks for your feedback. If you like to review the plugin you make me a lucky guy:)

    Same thing here.

    If I switch to ‘Plain’ Permalinks, the site works. If I switch to ‘Post name’ Permalinks, all of the links redirect back to the old site.

    I’ve switched a dozen times and still no change. I have another staging site on this server and the permalinks work, I’m not sure why this staging site refuses to update the permalinks.

    Here’s the System Info

    -- Webserver Configuration
    
    PHP Version:                                            7.1.7
    MySQL Version:                                          5.7.19
    Webserver Info:                                         Microsoft-IIS/8.5
    
    -- WordPress Configuration
    
    Version:                                                4.9.1
    Language:                                               en_US
    Permalink Structure:                                    /%postname%/
    Active Theme:                                           Alliance Dev 1.6
    Show On Front:                                          page
    Page On Front:                                          Home (#2)
    Page For Posts:                                         Unset
    Remote Post:                                            wp_remote_post() works
    Table Prefix:                                           DB Prefix: wpstg1_ Length: 7   Status:  Acceptable
    WP Content Path:                                        C:\Intranet\dev-site2/wp-content
    WP Plugin Dir:                                          C:\Intranet\dev-site2/wp-content/plugins
    WP Uploads Dir:                                         C:\Intranet\dev-site2/wp-content/uploads
    WP_DEBUG:                                               Disabled
    Memory Limit:                                           1024M
    Registered Post Stati:                                  publish, future, draft, pending, private, trash, auto-draft, inherit
    • This reply was modified 1 year, 1 month ago by wimadmin.

    Disregard. URL Rewrite was enabled on the subfolder in IIS. 🙂 Once I disabled URL Rewrite, the links worked.

    As an addition to the solution that worked for me:

    If it doesn’t work, it could help to deactivate all plugins but WP-Staging first then switch the permalinks and finally activate your plugins again.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Links Redirecting To Old Site’ is closed to new replies.