Support » Plugin: Elementor Addons - PowerPack Addons for Elementor » links not working with WPML in translated content

  • Resolved sanderkooger

    (@sanderkooger)


    Guys first off amazing elements!

    I just came out of a troubleshoot with Laura from WPML

    Problem: Internal Links on translated content point to original language.

    User puts a PP component on his page and adds a internal link to another translated page. then user translates page to another language, links in the translation are pointing to the original language.

    Expected behaviour, internal links in french page should link to their french counterparts.

    Sandbox https://race-2-breathe.com/widget-test-page

    Default Elementor components do no display this behaviour.

    Could you guys look into this, I have experienced the same with other element packs.

    Workaround:
    Translate the page, after translation manually edit every link. This works until something changes on orig language Every update of translation will copy faulty links back and break the links again.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Puneet Sahalot

    (@puneetsahalot)

    Hi @sanderkooger

    I am sorry for the inconvenience caused and thanks for sharing the details.
    Our development team has fixed the issue and will be releasing an update on Monday.

    Once the update is out, please try out to the new version and let us know if it works or not.

    We have tested it locally and it works for us. But it will be good to get a confirmation from your end.
    Thanks!

    sanderkooger

    (@sanderkooger)

    Will do,

    I have been going over it and it seems like more was not Multi lingual supported. Do you guys have a place where I could drop issues I find on testing?

    Regards,
    Sander

    Plugin Contributor Puneet Sahalot

    (@puneetsahalot)

    Hi @sanderkooger

    Yes, we figured out during our testing that WPML integration was missing in a number of places. So, we have updated all the widgets.

    If you have any more feedback, you can add it to our Github Repo
    https://github.com/helloideabox/powerpack-lite-elementor/issues

    🙂

    Thanks for all your time and support!

    Plugin Contributor Puneet Sahalot

    (@puneetsahalot)

    Hi @sanderkooger

    We have released the update today for WPML fixes
    Will mark this as “resolved”. 🙂

    If you have any questions or come across any issues, please feel free to open a new thread or report it on Github.

    Thanks!
    Puneet S.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘links not working with WPML in translated content’ is closed to new replies.