WordPress.org

Support

Support » Themes and Templates » [Resolved] Links not working on blog page

[Resolved] Links not working on blog page

  • I am using the latest version of the theme (1.6) and WordPress 3.8.1. Links in the blog page don’t work. If I click on the post, the links were perfectly fine. You can see at:

    http://www.mjl-tech.org

    The third test blog post has a working link. I’ve tried swapping out to the default theme, and it works perfectly fine.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author Guido

    @guido07111975

    Hi,

    Strange. But I cannot visit your site, please check your URL, guess it’s not correct.

    Guido

    Sorry, I had a brain fart.

    http://www.mjl-tech.com

    thanks!

    Theme Author Guido

    @guido07111975

    Hi,

    You do not see links in homepage posts because it’s the excerpt > if you want to display links in homepage posts you should open file index and replace this:

    <?php the_excerpt(); ?>

    With this:

    <?php the_content(); ?>

    But now whole post text is displayed. If you don’t like that you should add a more tag in your post text to break it on homepage.

    Guido

    Thank you so much for the quick response. Will this file be over written in theme upgrades? Could you make this an option in the customization for the theme?

    Thank you again!

    Theme Author Guido

    @guido07111975

    This will be overwritten indeed.
    I cannot add this option, because my themes are without a theme options page.
    So you can create a child theme and add the adjusted index file to the child folder:
    https://codex.wordpress.org/Child_Themes

    Guido

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Links not working on blog page’ is closed to new replies.