Support » Fixing WordPress » Links not working in Google Chrome, but work with all other web-browsers.

  • Resolved Adam_Murphy



    I have a problem with my wordpress site ( – suddenly, without making any apparent changes, the links stopped working in Google Chrome (even with the last version) – meaning that the page is useless to all users using Google Chrome (which is about 20% according to my google analytics). Naturally, this is a major problem, which I could really need your help with. I was hoping that it would sort itself out with a Google Chrome update, but unfortunately it didn’t.

    I searched the forum and found a similar problem with google chrome:

    But this error was specifically linked to a plugin “Simple Page Sidebars”, which we are not using here at our website. The author of the SPS plugin thought it was linked to CSS problems, but keep in mind I did not do any changes before the error occurred.

    Would be very grateful for any help on this matter. Thank you in advance.

    – Adam

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator Andrew Nevins


    Have you tried deactivating all plugins to see whether any could be responsible?

    Thanks for the suggestion, Andrew Nevins. Gave it a go, but no change unfortunately.. :/ Plugins we run are:
    – BAW Manual related post
    – Duplicate post
    – Google analytics Dashboard WP
    – WordPress Jetpack
    – Nivo slider
    – Sucuri security
    – Updraftplus
    – Video thumbnails
    – Woocommerce

    Any other ideas?

    – Adam

    Moderator Andrew Nevins


    Hi Adam, I know it’s a big ask because it’s your live site but could you keep them deactivated while we diagnose what’s wrong?

    Oh, ok. 🙂 Sure thing, Andrew. Will keep them deactivated for 1 hr starting in 5 minutes. Thanks for helping me out.

    Hmm.. the only plugin I did not deactive was WordPress SEO by (scared of losing all the meta descriptions etc.). Is that ok?

    Moderator Andrew Nevins


    Sounds like that’s fine.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    It’s probably OK but if you want to be safe (safe is good) then make a full file and database backup of your installation.

    That way even if you somehow do lose those settings then you’ll be able to put it all back.

    With that plugin I think it will preserve it’s settings but I’m a real fan of safety nets too. 😉

    Moderator Andrew Nevins


    The issue is caused by a style applied to the logo in the footer:

    #footer_logo {
     width: 306px;
     background: url(assets/img/footer-logo.png) top left no-repeat;
     height: 65px;
     display: block;
     text-indent: -99999999px;
     margin: 0 0 8px 0;

    Specifically this style:

    text-indent: -99999999px;

    Thanks for your concern, Jan. Did a manual backup yesterday uploading the public_html folder manually to a folder on my computer using FileZilla. Hoping that would do the trick if anything was to happen. 🙂

    Andrew Nevins: YOU, MY GOOD MAN… ARE A LIVING LEGEND! Thank you so much! Any ideas on how to resolve the issue? What parameters I should set it to, for example?

    Moderator Andrew Nevins


    Your footer logo doesn’t have any text so you can remove that style.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Hoping that would do the trick if anything was to happen. 🙂

    I’m really glad it’s working (Andrew is really good BTW) but the DB portion where the settings aren’t in the files. Give those links a read. Your installation is valuable and have it backed up somewhere will let you sleep nights. 😀

    Ahh, was unaware of that, Jan. Thank you!

    Finally managed to track down

    “#footer_logo{width:306px;background:url(assets/img/footer-logo.png) top left no-repeat;height:65px;display:block;text-indent:-99999999px;margin:0 0 8px 0}”

    in the CSS-stylesheet. Just to be totally noob (and safe!) Can I safely remove this section ‘no-repeat;height:65px;display:block;text-indent:-99999999px;margin:0 0 8px 0’ ?

    What an educational sunday this is turning out to be – THANKS and thumbs up to the two of you!

    Moderator Andrew Nevins


    It looks like your theme is using some sort of CSS minification. Making a change in the minified file will be a temporary fix.

    We don’t know how your theme was built (assuming it is custom), but generally you need to track down where your original CSS is and then remove this style:


    Oh, just realized you told me the answer already.. silly me! Sliced out ;text-indent:-99999999px;margin:0 0 8px 0′ and now it is working PERFECTLY with Google Chrome. Should have come to you guys sooner. #Legends #RESOLVED #THANKS!

    I did, Andrew. Thanks! Have a great day. 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Links not working in Google Chrome, but work with all other web-browsers.’ is closed to new replies.