Support » Plugin: LuckyWP Table of Contents » Links not working

  • Resolved Novogrowth

    (@meliory)


    Hi there,

    I am using Uncode theme and WP Bakery page builder.
    I have inserted WPLucky ToC with “Table of contents” button in text block and also by widget. In both cases, links do not work.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author LuckyWP

    (@theluckywp)

    Hello!

    Unfortunally, Unpod Theme used specific version of WP Bakery page builder uncompatible with LuckyWP Table of Contents.

    You can try replace code in wp-content/themes/uncode/single.php:

    <div class="post-body">' . uncode_remove_p_tag($the_content) . '</div>' .

    to:

    <div class="post-body">' . ($with_builder ? apply_filters('the_content', $the_content) : uncode_remove_p_tag($the_content)) . '</div>' .

    This solution should work. But we need to see – that everything else is displayed correctly.

    • This reply was modified 10 months, 2 weeks ago by LuckyWP.

    Thanks for the immediate reply!

    Plugin Author LuckyWP

    (@theluckywp)

    Did you manage to resolve the problem?

    Hi, unfortunately no. This does not seem to work.
    I am trying to apply the changes to my child theme.

    Any other ideas?

    Plugin Author LuckyWP

    (@theluckywp)

    What you modify?
    You need apply changes to Unpod Theme…

    I am uploading the file single.php to the child theme and apply the change you proposed.

    Obviously, I don’t want to edit the main theme.

    Plugin Author LuckyWP

    (@theluckywp)

    Can you send me theme and child theme?

    sure, I will upload it with wetransfer and send you the link in a moment

    Plugin Author LuckyWP

    (@theluckywp)

    Please, send link to general@theluckywp.com

    Plugin Author LuckyWP

    (@theluckywp)

    @meliory I copy single.php from uncode to uncode-child and modify him (see my post above). And this helped — table of contents good work.

    May be you don’t activate unpod child theme ?

    Hi,

    I have done this correctly but it does not work. The only way is to assign the headings id manually

    Plugin Author LuckyWP

    (@theluckywp)

    If not modify code and add shortcode to HTML block.
    Table of contents show, but links not working?

    Plugin Author LuckyWP

    (@theluckywp)

    What is Post Type where you use Table of Contents?

    Plugin Author LuckyWP

    (@theluckywp)

    Seem I found solve 🙂 Post Type — page.

    Copy wp-content/themes/uncode/page.php into child theme and replace

    <div class="post-body">' . uncode_remove_p_tag($the_content . $content_after_body) . '</div>

    to:

    <div class="post-body">' . ($with_builder ? apply_filters('the_content', $the_content) . uncode_remove_p_tag($content_after_body) : uncode_remove_p_tag($the_content . $content_after_body)) . '</div>

    • This reply was modified 10 months, 1 week ago by LuckyWP.

    Correct. If I don’t modify anything, the ToC shows but links do not work.

    I add the shortcode with “Table of contents” button on text block.

    The problem is that the headings don’t take id automatically.

    The post type is page.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Links not working’ is closed to new replies.