Support » Plugin: Coupon Creator » Links not showing up

  • I can’t get links to appear in the descriptions within each coupon.

    I asked my developer to help, and this is what he said “You can add links in the coupons’ content field just fine and it’s working in the dashboard but the coupon plugin is removing them from the frontend so only the linked word is appearing there but it won’t be clickable. Most likely there’s a function in the plugin which removes the entered “a href” HTML code before dumping the results to the frontend. It’s a common security feature to avoid malicious code parts to be running but the developer could easily deactivate it or they could create an option for the owners toggle to enable/disable it if necessary. So currently my only advice regarding this is to ask the developers about it and hopefully they can offer a solution or an option in the next releases.”

    Can you please advise how I can get around this so the links will start to appear? I have the pro version of the plugin.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Brian

    (@brianjessee)

    Hi,

    Thanks for using the Coupon Creator Pro.

    Here on the WordPress.org forum, I’m afraid we do not provide technical support for our premium plugins. I would ask that you take any technical support questions across to our premium forum where we will respond to you within 24 hours during the week:

    https://couponcreatorplugin.com/support/contact/

    Having said that I can get you started on this. The links are removed from the coupons, because the coupons themselves are links and you cannot have links in links. There are newer coupons and options in Pro that disables the coupon being a link, but it was always designed to be one link itself.

    I reviewed and the coding has a filter for the free version, but not the pro version to enable links.

    However, if you change this a line of code in this file:

    wp-content/plugins/coupon-creator/plugin-engine/src/Pngx/Field/Content.php

    On line 59 from this:
    <?php echo strip_tags( $meta, Pngx__Allowed_Tags::$tags() ); ?>
    To this:
    <?php echo strip_tags( $meta, apply_filters( 'pngx_filter_content_allowed_tags', Pngx__Allowed_Tags::$tags() ) ); ?>

    That will add the filter I will include in the next release. You can then use this snippet to enable links:

    add_action( 'wp_head', 'cctor_enable_links' );
    function cctor_enable_links() {
    	add_filter( 'pngx_filter_content_allowed_tags', array( 'Pngx__Allowed_Tags', 'content' ) );
    }

    Add that to a child theme or custom plugin.

    Thanks again!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.