Support » Plugin: Multiple Domain Mapping on Single Site » Links not changing and 404 posts not found

  • Hi,

    I am trying to setup domain aliases for my site. Currently I did a remap from second domain alias to a specific page. It works. But two problems appear.

    1. I want users to stay on that second domain when they continue to browse, this means all links have to change to a second domain when user visits it. Problem is that they dont. Any link that is using get_permalink or similar default WP functions stays the same. If I manually edit the wp-config file and change WP_HOME and WP_SITEURL to ‘SERVER_NAME’, all links change too. But this plugin should do that by default, no?

    2. Any post or page, that I try to reach using the second domain is not working and shows 404 Error. How strange is that? Everything works on main domain, but not on a second alias domain. What could be the issue? No connection with me editing wp-config file for the first problem. .htaccess is rather default, except for the caching settings for images and files. Could be connected?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Update: getting 404 error only when domain is added to mapping. Tried with another domain and all pages work.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    please try to provide more information like described here. https://wordpress.org/support/topic/support-rules-2/

    Hi. Sorry, not sure how a screenshot would help.

    Here you go, just removed my page url.
    http://foto.terpe.lt/inkelti/20200910/i59_Screenshot%202020-09-10%20093417.jpg

    Again, only when this mapping is turned on, I get 404 errors. Tried playing with different settings, changing from SERVER_NAME to HTTP_HOST. Also checked debug log, saw no apparent errors.

    .htaccess has these rules:

    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ https://%1%{REQUEST_URI} [R=301,QSA,NC,L]
    
    # BEGIN WordPress
    # The directives (lines) between "BEGIN WordPress" and "END WordPress" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Plus mod_mime for AddType, mod_expires for caching, Deflate.

    Hi. Still waiting for help.

    Looks like the problem occurs only when I setup my secondary domain to link to specific page. So in settings:

    http[s]://domain2com => https://domain1.com/mypage

    This works for home page and when visiting domain2.com I see ‘mypage’ as homepage. However if I try to go to other pages, I keep getting 404 error. If I remove this setting and just keep this:

    http[s]://domain2.com => https://domain1.com/

    Then everything works. So to me it looks like your plugin is trying to redirect all pages to domain1.com/mypage even when I am going to domain2.com/myanotherpage it tries to open domain1.com/mypage/myanotherpage. Probably, Im not sure. But it def. looks like it. By default it probably should redirect only the homepage, not all other pages.

    Plugin Author matthias.wagner

    (@matthiaswagner)

    hy,
    there was no further response since you did again not deliver a screenshot with domains visible 😉 you will understand that we can not find out any more if we can not have a look at your site…

    anyway, the behaviour you described in your last paragraph is true. the plugin will always perform “wildcard”-mapping for all sub-urls of those defined mappings. this is something we won’t change, since it’s the default behaviour since the beginning of this plugin.

    let me know, if everything is clear now for you.

    matt

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.