Support » Plugin: WP News and Scrolling Widgets » Links not active if I use content_words_limit parameter

  • Resolved jkrakar

    (@jkrakar)


    Hi. I’m using the shortcode for the news feed on my home page to preview the latest news (the site is not live yet so I can’t post a URL for the site). This is the shortcode I’m using: [sp_news grid=”list” limit=”5″ content_words_limit=”50″]. The problem is that if there is a hyperlink in the preview, it won’t be active unless I change the shortcode to show_full_content=”true”. I’d like for the hyperlinks to show up in the preview on my home page because otherwise it’s confusing if it says “click here” or “go to this website” and nothing happens. Is this possible to fix? Does the paid version allow for hyperlinks to be active when a word limit is set?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Ketan Patel

    (@patelketan)

    Hello,

    Thanks for reaching here.

    You want to show_full_content=”true” and “read_more” button at a time display.
    Sorry, Our plugin does not display the “read_more” button and show_full_content=’true’ at a time.

    Please add this shortcode.
    [sp_news grid="list" limit="5" show_full_content="true"]

    Note: Please do not copy and paste the shortcode parameter because it causes the quote(“) issue. Please write manually.

    Please check and let me know if you anything else.

    Thanks,

    Thread Starter jkrakar

    (@jkrakar)

    No, you misunderstood what I was trying to say. When I use this shortcode [sp_news grid=”list” limit=”5″ content_words_limit=”50″], the hyperlinks in my news articles are inactive. I don’t have room on my home page to show the full articles, but I would like the hyperlinks to work, or else it’s confusing for the readers.

    Plugin Contributor Ketan Patel

    (@patelketan)

    Hello,

    Thanks for reaching again.

    Please try permalink reset and check.
    Please go to your dashboard Settings-> Permalink setting page. common settings select “Plain” and click the save button and again select “Post Name” and click the save button.

    Please check and let me know if you anything else.

    Thanks,

    Thread Starter jkrakar

    (@jkrakar)

    That didn’t do anything. The hyperlinks are still inactive if I limit the amount of words displayed and use the “Read More” feature. Any hyperlink to external or internal resources are inactive. The “Read More” link is the only active link.

    Thread Starter jkrakar

    (@jkrakar)

    In the code view for the webpage, this is an example:

    <div class=”news-short-content”>
    School will be closed on Wednesday, Nov. 11 in honor of Veterans Day. Click here for the schedule for the week of Nov. 9-13: ENGLISH | ESPANOL
    </div>

    The hyperlinks are stripped out of the text.

    Plugin Contributor Ketan Patel

    (@patelketan)

    Hello,

    Sorry, Our plugin does not display for short description any HTML tag.
    you add show_full_content value true and you use our shortcode.

    Thanks,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.